Main Site Documentation

Updated firmware, prior to loader (fez spider). Cannot seem to update loader now?


#1

Hello all,
I know (but it’s too late now?) that I should have installed the tinybooter/loader first and then the firmware, but the FezConfig tool sent my intuition in another direction.
I have now the following versions:
[em]Loader (TinyBooter) version information:
4.3.3.0 on this computer.
4.2.11.1 on this device.

The Loader (TinyBooter) not up to date. <<<
[/em]

[em]Firmware (TinyCLR) version information:
4.3.3.0 on this computer.
4.3.3.0 on this device.

The Firmware (TinyCLR) is up to date. <<<[/em]

Whenever I try to update the tinybooter now, I get the error that the device is not connected. I tried on USB 3.0 and USB 2.0, I tried with powerd USB hub and without, I tried on 2 seperate computers (installing vs+netmf on the third).

Is there something I can do to fix this one? (have a presentation tomorrow and want to include my device demo)

Best regards


#2

sometimes he doesn’t recognize the device
other times it’s shown as the GHI loader


#3

Tiny booter should be updateable at any time, no matter what firmware is installed.
Even a defective firmware can normaly not block the bootloader update.
Which device do you have?
How do you set your device in loader mode?
What device does Windows Device Manager show?
Do you have any other USB Serial converter connected to your PC?


#4

thanks for the feedback
My device is a Fez Spider I
I set my device in loader, by switching the 3 jumpers as indicated on the images (jumper 1-2-3)
The device that I see in WDM is sometimes good (GHI Loader, or something like that) or sometimes ‘not recognized’ - no real pattern on when it’s good and when not.
But even when it’s recognized, the update doesn’t work.
I disconnected all other USB devices to make sure to have maximum power and no interference.


#5

Hello,
It is indeed a Windows 8.1 PC. I am now trying it on my wife’s PC (I hope she won’t mind having Visual Studio installed on it, lol).
That PC is a Win8 and there it seems to be working !
I’m wondering what the root cause could be? Would be helpful not only for me, but also for other people who might see the same behavior


#6

The Windows 8.1 thing should be a red-herring. I have Windows 8.1 on my laptop and was able to update the loader and the CLR to the latest version just a few weeks ago on my Spider 1.

With no modules plugged into the Spider and a separate power supply into a USB-DP module things were stable and the update ran from start to finish without hiccups.

Without the external power the Spider connected and disconnected consistently.

Good luck and please be sure to keep the group updated if you fix your problem.


#7

Also the USB cable is often a problem. They too cheap now a days.

I never had any problems with any windows version from W7 to 8.1.
I prefer USB 2.0 ports, even that I never had USB 3.0 problems.

You say sometimes it’s shown correctly in device manager. What happens when you update at that time? Or does it switch to not recognized by it self?


#8

@ andre.m - Typo. Should have said red-herring. That is to say, not really the main problem.,

J.


#9

@ andre.m - I had read some Windows 8.1 issues but I certainly never experienced them. For me it was all about the power. I’m sure it’s frustrating though.