Update 2 Program.gadgeteer Toolbox VS 2010 Express

It’s me again with another off-the-wall question.

When creating a new Gadgeteer application this morning (and looking at old builds) I now find that the Program.gadgeteer Toolbox list no longer shows an item for the ‘Text’ or was it called a ‘Comment’ box.

When creating a new Gadgeteer application the ‘standard’ Text box shows up in the designer but there is no item in the toolbox to create a new one.
Right click of mouse does not show a ‘copy’ option and I cannot drag it into the toolbox (Thought that maybe I could add it into the toolbox that way).

Anybody know how to solve this?

Not the ‘End of the world’ thing but…

I removed ALL .net, .net micro, all sdk’s (even my netduino items). I did a repair on visual studio and reinstalled everything (For GHI I did in order stated for 4.1 to 4.2.

Same as it was before?

In designer toolbox
right click, show all

Find the List … Heading Gadgeteer
(only shows grayed out items in list)
Socket Connection

Jumping out of the window as soon as I have a drink…

So everyone does not think I am completely nuts…

I have included two new images of a application I posted awhile back. As you can see in the gif I was using the GHI .Net Micro 4.1.

The application designer contains two Comment text blocks. Installing the new GHI 4.2 must have broken the option of adding sdditional comments.

I tried installing the GHI (Optional) GHI NETMF v4.1 and .NET Gadgeteer Package Sep. 14, 2012 on my laptop but this version is apparently not the same as what I installed when I got my Fez.Spider. Installing the Sep. 14, 2012 version does not provide all the steps (USB driver install, firmware update etc) as I remember that the original installition files did. DANG ME! … I must have erased the original files because I cannot find the original install files I used.

Sure would be nice if the new 4.2 could include the old ‘feature’. Can’t see how it yould hurt anything…

Last post on the subject!


I don’t think there is a way. If you look at the Program.gadgeteer file’s raw xml, you will see that it treats that box as a special . I tried adding another comment section and it seems the schema doesn’t allow it.


I wonder what happened?

The Heading Gadgeteer and its choices (Pointer, Comment and Socket Connection) have always been there (and active) since I first installed the GHI software when I received my Spider. I have used multiple comment boxes many times. I did nothing special to put it there. I thought every GHI user had the choice in their Visual Studio.

Where do I find the Program.gadgeteer file’s raw xml you mentioned?

Is netduino considered a Gadgeteer? I had .Net Micro installed with their SDK before I bought my Spider.

Interesting. I don’t get a “Gadgeteer” toolbox section. I do remember seeing it before but I no longer have it. I wonder if the 4.2 SDK install removed it.

Right-click on “Program.gadgeteer” in the Solution Explorer and choose “Open with…” -> “XML (Text) Editor”

There are no netduino Gadgeteer boards. They have their own flavor called Go!