Main Site Documentation

Unable to deploy after PC wakes from hibernate


#1

I often hibernate my PC instead of shutting down.

But after my PC wakes up from hibernate, I’m not able to deploy to my FEZ Cobra. I need to reboot my PC in order to get things working again.

Anyone had similar issue and perhaps a solution?

Thanks


#2

Even after pulling out usb and reinserting?


#3

Tried it many times, but doesn’t work either.

I think it’s a problem with the driver or something. The USB port where the FEZ was connected to, doesn’t accept any other USB device like mouse, keyboard, memory stick, … until reboot. Also when disconnecting the FEZ, I don’t here the disconnecting sound.

Other ports are working fine, but when I insert the FEZ into an other USB port, I don’t here the connecting sound, nothing happens.

A reboot is the only way to solve this problem right now.

When I have it again, I’ll see if I can disable and re-enable the driver from the Hardware list.


#4

I never shutdown, only hibernate and never had similar problem.


#5

the problem started when I switched to a new PC with a 64bit version of Win7 (previously I was on 32bit version of Win7 and did not have that problem)


#6

Hi community,

Same problem here in Holland (The Netherlands, not Holland Michigan ;)).
Exactly the same. Hearing no connect or disconnect sound.
I’m also on a Win7/64 bit laptop system. Probably a driver issue?
According to DriverMax I’m packed with the latest drivers, it a Dell laptop.
So I never hibernate it anymore, I have to reboot anyway.

My Win7/32 bit desktop doesn’t have this problem.

Cu Wim.


#7

me also a Dell laptop, and USB 3.0 ports


#8

I have couple 64-bit PCs and the USB works fine with hibernate.

Force uninstalling the drivers with the driver files. Maybe Winodws USB driver is getting crazy somehow.
And look for a driver update forthe USB controller.


#9

Personally, I blame the Windows USB stack.

I have had that happen to me, before I got my first Panda. All the plugged in devices would work, except one. Plugging any usb device out and replugging it, the PC would not detect that device again. IE, keyboard worked, till I unplugged it, it wouldn’t reconnect after replugging.

Maybe this is different. Dunno…


#10

Since USB 3 is relative new it could idd be the driver


#11

I had exactly the same problem with Panda II’s and a new Win7 64bit laptop. In addition to making the usb unusable it would freeze the panda Datalogger.

The problems all went away when I installed Service Pak 1 for Win7.


#12

Same problem here, windows 7 64bit.

Driver reinstall is of no use, USB2. On reboot I get a bluescreen regarding fez usb drivers.


#13

Try this: disconnect FEZ and shutdown VS before hibernating. After hibernate, reconnect FEZ and restart VS. It seems to work. (everything is ok, as long as I don’t have to reboot :stuck_out_tongue: )


#14

Update to a statement I made here yesterday. When I installed Win7 Service pack 1 the issue of usb ports becoming unusable disappeared. But hibernation is still freezing the Panda application. Here is a sample of the datalog, with only a portion of the columns for brevity.

2011-06-12-21-00-04 317.32 98.52 212.82 129.84 43.05 23.19 23.61
2011-06-12-21-00-09 315.51 99.59 212.96 129.39 42.07 22.89 23.81
2011-06-12-21-00-14 315.17 97.57 212.19 129.13 42.1 23.76 24.96
2011-06-12-21-00-19 314.42 98.45 212.66 129.86 42.4 23.19 25.08
2011-06-12-21-00-24 314.66 96.39 213.41 128.57 42.84 23.59 25.28
2011-06-12-21-06-33 271.54 88.11 186.93 115.83 41.04 26.88 21.7
2011-06-12-21-06-38 272.54 88.93 186.09 114.97 41.56 27.18 21.89
2011-06-12-21-06-43 270.13 89.51 186.19 114.41 40.91 27.1 22.34
2011-06-12-21-06-48 270.35 90.84 185.69 116 39.24 25.44 22
2011-06-12-21-06-53 271.65 90.09 185.55 115.52 40.17 25.5 21.89
2011-06-12-21-06-58 271.59 90.07 185.15 113.85 39.95 26.52 23.28
2011-06-12-21-07-03 269.82 87.45 184.59 114.62 39.38 25.76 23.01

If you notice the timestamp at 00-24, that is where the laptop went into hibernation and the panda froze. I unplugged the usb port at 06-33 and it started running again. It would be nice if this issue was resolved as you can’t leave the laptop running in debug mode without not allowing to hibernate, which is not a great thing for a laptop.


#15

Ah Hah! I found a solution, for my Panda’s and my systems and the reason why it has never been a problem on my desktops.

Go to power options and advanced settings and turn OFF the password required after sleep or hibernation. No more frozen screens and lost data.

The reason it never happened on the desktops is that they all default to no password required.

Hope this works for your systems.


#16

That solution was somewhat shortlived. It worked great until I rebooted the laptop and it went back to freezing the Panda on awakening from sleep or hibernation. I disabled the passwords and the fingerprint reader and when the laptop wakes up it is saying something to the Panda that freezes it in it’s tracks. Most annoying!

If you unplug the Panda before hibernation it is fine but you will have to view debug info after connecting with mdeploy when you start over.