Unable to debug Fez Cobra 3 or G120TH

Now faced with a new problem. I am unable to debug. The debugger is not able to attach (Object reference error), to either my Fez Cobra 3 or G120TH module. I can however Update the firmware with FezConfig, deploy the application in Visual Studio, and wipe the application with Fez Config. I’ve also tried switching to Serial Debugging which also failed.

I’m fairly sure this is a typical problem, but I can’t seem to find the resolution on the forum.

1 Like

After switching among all the USB ports on my system, I found a port that allows me to debug. I tried this port before but it didn’t work. I guess I have hardware issues.

2 Likes

The problem occurred again last night. Rebooting didn’t work, switching ports didn’t work. I concluded that it has to be a software problem. I uninstalled the Visual Studio 2017 beta, stripped off all of the GHI products, and uninstalled the driver. I reinstalled only the latest SDK (GHI Electronics NETMF SDK 2016 R1). Debugging works again. We’ll see how long it lasts.

1 Like