Trouble updating firmware (FEZ Hydra)

I have my fez hydra connected to th USB DP Client, and I´m trying tu run a simple program that only has a debug.print. The problem that I´m having is that when I press debug It says “Preparing to deploy assemblies to the device” but after that nothing happens. I pressed the reset button and I got this message:

Using mainboard GHIElectronics-FEZHydra version 1.0
Creating extended weak reference to store LCD configuration. (You should not see this message unless the mainboard is new or has its firmware updated.)

I´ve waited for 20 minutes and nothing.

I pushed the reset buttom one more time, disconnected and connected the usb cable and reinstalled the drivers. Non of these things works. I even tried to update the fez hydra firmware but I couldn´t, I got an error that says: “Sig image files do not exist”. I couldn´t make a ping to the device either.

Make sure the GHI SDK / Gadgeteer SDK / Micro Framework SDK are all the latest version. Details here:

What happens when you try to ping it with MFDeploy? (located in \program files.NET Micro Framework\Tools)

The most common mistake is not having the latest firmware. Please make sure you have the latest SDK, see release notes. After installation, make sure you’ve loaded the latest firmware on the device. The firmware is updated though the integrated updater software found under the start menu. If that fails, or if your device doesn’t have such software, you can always run the update manually.

(Generated by QuickReply)

Thanks for your replays. I tried to ping the device using the MFDeploy but it didn´t work, I got an error that said “No response from device”.
I updated to SDK latest version and nothing has changed. When I used the Hydra Updater I got an error message that said “Failed to communicate to hydra”, then pressed the reset bottom and I got a message that said “Please wait. Connecting to device”, but I waited for 15 minutes and nothing.
I will try to do it manually.

Did that get you going? It should have. If you’re still having problems let us know. Also, make sure you are using a powered hub to power your Hydra. Poor power from your USB cable attached directly to your PC can also be the source of this problem.

does your PC have usb2 or usb3?

Thanks for your replies. I tried to update the FEZ manually by using the wire technique. When I tried to load the bootstrap I got a communication error and in the log file I only got this:

-I- Waiting …
-I- TCL platform : Windows NT
-I- SAM-BA CDC 2.10 on : windows
-I- Retrieved arguments from command line :
-I- argv 0 : com3
-I- argv 1 : at91sam9rl64-ek
-I- argv 2 : TinyBooterLoader.tcl
-I- Connection : com3 (target(comType) = 3)
-I- Board : at91sam9rl64-ek
-I- Traces Level : 4
-I- target(handle) : file109a668
Read device Chip ID at 0xfffff240 — get 0x66666677
Read device Chip ID at 0xffffee40 — get 0x34326666

Maybe the wire didn’t work but I don’t have an SD card to try something different.

@ maria.pb

Can you describe in detail the steps that you did to flash the board manually, and also how you typed in COM 3?

With the FEZ Hydra turned off I put a wire between pin 8 and 10 off the socket 3 (type s) and then I powered the fez. I waited 5 seconds and removed the wire. After that, I followed the steps for the load of the bootstrap.
In the commad prompt I typed “UpdateFEZHydra com3”

@ maria.pb

When you are doing the manual flash, do you have the command prompt in administrator mode?

Yes, I have it on administrator mode :frowning:

I would verify that the serial port is in fact COM3 and that there are no driver load issues. Open Device Manager and take a screenshot of it; that will help us confirm that the jumper wire has put it in bootloader mode properly and the port is right

I don´t have it on bootloader mode, it stayed the same way as it was before I used the jumper wire.

@ maria.pb

How are you shorting the wire? Do you have an extender module or are you trying to short the wire on the socket directly? If you are trying on the socket make sure that you are touching the correct pins. The correct pins ( 10, 8 ) are as followed:


9 7 5 3 1
10 8 6 4 2

It might be helpful if you have audio on your PC so you can hear the connect sound because once you hear it right away you would remove the jumper but do not reset the board or else it will go back to default TinyCLR loading. If you do not hear the sound right away the board did not short correctly. Do not leave jumper on the board longer than a few seconds.

If you have the correct Com port, the device manager will display something like: GPS Camera Detect (COM13).

I´m shorting the wire on the socket directly. I tried it again and even though I heard the connect sound, the fez is still connecting as a “USB debugging interface”. I´m pretty sure I touched the correct pins so I don´t know why it´s not working.

… because you’re not holding the pins correctly or for the correct length of time. It’s not easy to maintain actual contact in the socket, so if you can I would use an extender module to get .1" header access to it. Much easier. If you had do, the other alternative is to use a cable connected to the socket itself and use thin wire in the female connector to get best connection.

Since I don´t have an extender module I connected a cable to the socket and used thin wire in the female connector. When I connected the module to the USB port the computer said it was an “unknown device” and I couldn´t do much from there.

keep trying, as @ Aron said it should show up as a COM port that shouldn’t need a driver.