Trouble running Cerberus for the first time

I just purchased a Cerberus and am having trouble getting it to run/debug.

I have installed .net micro framework 4.2 RTM (QFE2)
I have installed Visual Basic Express instead of C# (because i hate semicolons).
I have installed GHI NetMF 4.1/4.2 package (RC2 8-24-2012)
I have upgraded the Cerberus’s firmware: config.hex,firmware.hex 8/28/2012
I did not bother with the bootloader stuff I assume that isn’t really necessary.
I can ping it with MFDeploy.

When I write a simple program to turn on a LED on the LED7r and download it I get the following from the debug window:

Found debugger!
Create TS.
Loading start at 805b7e0, end 80843fc
Assembly: mscorlib (4.2.0.0) Assembly: Microsoft.SPOT.Native (4.2.0.0) Assembly: Microsoft.SPOT.Hardware (4.2.0.0)
Assembly: Microsoft.SPOT.Graphics (4.2.0.0) Assembly: Microsoft.SPOT.TinyCore (4.2.0.0)
Assembly: Microsoft.SPOT.Hardware.SerialPort (4.2.0.0) Assembly: Microsoft.SPOT.IO (4.2.0.0)
Assembly: System.IO (4.2.0.0) Assembly: Microsoft.SPOT.Hardware.OneWire (4.2.0.0)
Assembly: Microsoft.SPOT.Hardware.Usb (4.2.0.0) Assembly: Microsoft.SPOT.Hardware.PWM (4.2.0.1)
Assembly: Microsoft.SPOT.Net (4.2.0.0) Assembly: System (4.2.0.0) Loading Deployment Assemblies.
Attaching deployed file.
Assembly: Microsoft.VisualBasic (1.0.0.0) Attaching deployed file.
Assembly: GHI.OSHW.Hardware (4.2.2.0) ***********************************************************************

  •                                                                 *
    
  • ERROR!!! Firmware version does not match managed code version!!! *
  •                                                                 *
    
  •                                                                 *
    
  • Invalid native checksum: GHI.OSHW.Hardware 0x73150480!=0xF0D4135D *
  •                                                                 *
    

Resolving.
The debugging target runtime is loading the application assemblies and starting execution.
Ready.
Cannot find any entrypoint!
Done.
Waiting for debug commands…

What am I doing wrong??
Thanks,

Vic

Welcome to the forum.

Looks like the firmware update did not work correctly.

Follow all the steps described in Home - GHI Electronics, including the bootloader.

Just soldered in a 2 pin header and jumped it to update the bootloader.
Erased chip and successfully updated the bootloader.
Flashed the config & firmware.hex 8/28/2012

restarted VBasic and I still get the same error.

Curious, do you get this in c# app?

Is this a new project you made with zero changes? Netmf or gadgeteer?

The latest version of the GHI OSHW library is 4.2.3.0. Looks like you have an old project.

You can try to remove all the GHI and MS references from your project and then add them back. If this does not work, then start with a new project.

Thanks,
I guess that was it. Got it working, I completely uninstalled everything except visual studio
and downloaded and installed again. I can toggle the on board LED now.
Heres the new output.

Found debugger!
Create TS.
Loading start at 805b7e0, end 80843fc
Assembly: mscorlib (4.2.0.0) Assembly: Microsoft.SPOT.Native (4.2.0.0) Assembly: Microsoft.SPOT.Hardware (4.2.0.0)
Assembly: Microsoft.SPOT.Graphics (4.2.0.0) Assembly: Microsoft.SPOT.TinyCore (4.2.0.0)
Assembly: Microsoft.SPOT.Hardware.SerialPort (4.2.0.0) Assembly: Microsoft.SPOT.IO (4.2.0.0)
Assembly: System.IO (4.2.0.0) Assembly: Microsoft.SPOT.Hardware.OneWire (4.2.0.0)
Assembly: Microsoft.SPOT.Hardware.Usb (4.2.0.0) Assembly: Microsoft.SPOT.Hardware.PWM (4.2.0.1)
Assembly: Microsoft.SPOT.Net (4.2.0.0) Assembly: System (4.2.0.0) Loading Deployment Assemblies.

Attaching deployed file.
Assembly: Microsoft.VisualBasic (1.0.0.0) Attaching deployed file.
Assembly: Gadgeteer (2.42.0.0) Attaching deployed file.
Assembly: System.Http (4.2.0.0) Attaching deployed file.
Assembly: Microsoft.SPOT.Net.Security (4.2.0.0) Attaching deployed file.
Assembly: GHIElectronics.Gadgeteer.FEZCerberus (1.0.6.0) Attaching deployed file.
Assembly: Microsoft.SPOT.Touch (4.2.0.0) Attaching deployed file.
Assembly: GHI.OSHW.Hardware (4.2.3.0) Attaching deployed file.
Assembly: GadgeteerApp1 (1.0.0.0) Attaching deployed file.
Assembly: System.Net.Security (4.2.0.0) Resolving.
The debugging target runtime is loading the application assemblies and starting execution.
Ready.