Trouble loading tinyclros on g400

My software effort on this project started 2 years ago on the hydra. It evolved to the g400d. Due to a recent dev board/g400 hardware failure I decided to bite the bullet and upgrade (my hardware and) development environment from netmf to tinyclr os. The hardware is new. Samba loaded the ghi bootloader ok, but the next step failed. Tinyclr config will not connect to the board.

Following the instructions to hold down sysb while resetting or powering up, the device manager shows:
GHI Bootloader Interface (COM10)

COM 10 shows up in tinyclr config too, but attempting to connect yields:
Connection Failed.

If I hold down sysa while resetting, device manager shows:
Bossa Program Port (COM9)

I know this isn’t supposed to work, and it doesn’t.

I loaded the previous version of tinyclr config and it does the same thing. I’m stuck. I seem to have hit a dead end.

If insanity is repeating an action while hoping for a different outcome, I’m there. What am I missing? Anybody?

hi MArk,

not sure where you’re at, but here is a safe place :slight_smile: is a recent thread that might have some links worth following. If you could tell us where along the process (from the bootloader doc in particular) you got up to and what if any messages things threw, that might help.

I’d figure out what the version of the GHI bootloader you have is, and report that back here, as usually that’s going to direct what next steps are…

Do to have v2 loader? Is this the page you used?

Hi Brett,
I did run into that post in my search for an answer. I decided to go to the latest versions of everything, hardware and software.

Hi Gus,
Yes, that is where I started. I installed samba 2.18 on my windows 7 machine and loaded bootloader v2.0.4 onto the g400. The next step is to use tinyclr config, but it will not connect as detailed above. Tinyclr config is version 0.12.0, but I did try a version 1 and it worked the same.

In my experience you need to make a serial connection and put the new firmware with tera term on the device.
so you are ready.
tinyclr on a device like hydra is not functional in my tests.


Are you trying to connect on the Debug tab or the Loader tab?

Hi John,
Tried both tabs. Port does not show up in loader tab. May be a clue. Don’t know.

Hi Andreas,
Thank you for the bad news. You are right.

Does it appear on the loader tab when you click refresh? Make sure to plug it in fresh and don’t use the debug tab at all.

also, can you document a table of MODE button states and power on results with device manager? Also make sure you test the no-mode behaviour, just the loader…

Hi John,
No matter what I did with the reset, sys buttons, plugging and unplugging, etc, the only port that showed up in the loader tab was com1, not correct. This device is coming in on com 9 or com 10 according to the first post I made. My conclusion is that tinyclr config does not work on my setup.

I was able to load the firmware manually without problems using a terminal emulator/xmodem.

Don’t have a table, but the sysa and sysb buttons present ports com9 and com10 in device manager.

Thanks for the suggestions guys. I’m off and running now. Cheers,

Now that you have the firmware is loaded, can you try TinyCLR Config to reload the firmware to see if it would work? Try it without any changed on load pins and try it with load pins please. This may give us more info on what went wrong.

Hi Gus,
I reinstalled tinyclr config (I had taken it off the system when I couldn’t get it to work), followed the directions and everything worked as it should. The only difference I can see is the g400 was new the first time around. I was confused because I thought it was some kind of win7 usb port issue…
Cheers, Mark

1 Like