Main Site Documentation

Trouble deploying to Fez Spider


#1

Hi,

I’ve got VS2012 installed on a Win7 X64 machine and tried to deploy the hello world project and got the following errors:

Looking for a device on transport 'USB’
Starting device deployment…
Iteration 0
Iteration 1
Iteration 2
Iteration 3
Iteration 4

I have up-to-date firmware in the device as per FEZ config:

Connecting to device…EMX_EMX
Loader (TinyBooter) Version: 4.2.7.0
Firmware (TinyCLR) Version: 4.2.10.1

and I have installed .net Micro Framework 4.3 and GHI Software Package v4.2

Any idea where to go next?


#2

@ jhoge123

Loader (TinyBooter) Version: 4.2.7.0
Firmware (TinyCLR) Version: 4.2.10.1

This is not correct. The TinyBooter should also be 4.2.10.0. How did you update the firmware? If you only used the Updater Tool or MFDeploy to update the firmware then you will need to also update the TinyBooter. You should look at this link for more information: https://www.ghielectronics.com/docs/54/firmware-update-emx


#3

Aron, I used Fez_Config to update the firmware. I guess it only does half the job.

andre.m, It looks fine in the device manager. It is listed as GHI .NET Micro Framework Device

I’m having trouble setting the configuration switches on the device to the loader mode. My switches appear to be covered by a yellow sheet of plastic. I’m not sure if it is meant to be removed because it doesn’t seem to come off very readily.


#4

Remove.


#5

OK I got it now. I found the updater under “legacy versions of firmware updaters…” on https://www.ghielectronics.com/support/.net-micro-framework