Main Site Documentation

Touchscreen Test


#1

HI Everyone.
Iv tried some sample software involving my touchscreen, but there is either a latched on input from the touchscreen or no input from the touchscreen.
Is there a simple touchscreen program I can use to test the touchscreen.
Iv checked through forum and web and cant find anything ?


#2

Well that ansers that question.


#3

Have you tried glide? http://www.ghielectronics.com/glide


#4

There’s also several examples over on code.tinyclr.com


#5

Hey Im back again. I feel at this stage im missing something very important. All of the software im trying is just failing. With the touchscreen Iv now tried several pieces of software. All have failed.
Heres the latest. (taken from tiny)

using System.Threading;

using GHIElectronics.NETMF.Glide;
using GHIElectronics.NETMF.Glide.Display;
using GHIElectronics.NETMF.Glide.UI;

namespace Test
{
public class Program
{
// The windows.
static Window window;
static CalibrationWindow calWindow;

    public static void Main()
    {
        // Load the window
        window = GlideLoader.LoadWindow(Resources.GetString(Resources.StringResources.Window));

        // Activate touch
        GlideTouch.Initialize();

        // Initialize the windows.
        InitWin();
        InitCalWin();

        // Assigning a window to MainWindow flushes it to the screen.
        // This also starts event handling on the window.
        Glide.MainWindow = window;

        Thread.Sleep(-1);
    }

    static void InitWin()
    {
        Button btn = (Button)window.GetChildByName("btn");

        // Open the calibration window.
        btn.TapEvent += new OnTap(btn_TapEvent);
    }

    static void btn_TapEvent(object sender)
    {
        // Switch to calibration window.
        Glide.MainWindow = calWindow;
    }

    static void InitCalWin()
    {
        // 1st argument is auto start, which immediately starts calibration once the window is open.
        // 2nd argument is auto save, which saves the calibration settings for future restarts.
        calWindow = new CalibrationWindow(false, false);

        // Close the calibration window.
        calWindow.CloseEvent += new OnClose(calWindow_CloseEvent);
    }

    static void calWindow_CloseEvent(object sender)
    {
        // Switch to normal window.
        Glide.MainWindow = window;
    }
}

}

The error Im gettingn is in " public class Program"The error Im getting is :_Error 4 ‘Test.Program’ does not contain a definition for ‘ProgramStarted’ and no extension method 'ProgramStarted’
accepting a first argument of type ‘Test.Program’ could be found (are you missing a using directive or an assembly reference?)
Iv done alot of porgramming before . Not on this type of epuipment, but iv never had these kind of problems before.
Surly a program for the Gadgeterr should just work. i need to know how the modules work before if can even try to do somethime.
i admit i feel like im in over my head here:)
Or just stuiped


#6

The code you just posted is not Gadgeteer code, it is EMX code.

Instead of building it with a Gadgeteer project template, use aEMX project template.


#7

Apart from some errors im getting. Which I cant get rid of.
I think my major problem now is Iv downloaded Glide but it wont open. Iv tried to download it unzip it and load it but I still cant get it to open. Computer says it does not know what software to open it with. I just transfered the fill to the dll area, but this did not work.
Is there extra software i need to run this app?


#8

For the past month Iv tried everything. I know software is not my major thing although i can program most other devices even at a basic level.
My big problem here is 1 most downloads will not open correctly.
2 sample software is bringing up too many errors. + this is gadgeteer software.
3 to program in any language is not to hard, but to understand what multiple dll codes are are required to run external devices is very hard without working examples.
Despite a month of work I can still only turn on and of an led. ( I was aiming for slightly better then that)
The spider looks like a great piece of gear but whoever said its a simple thing to program was just wrong.
Surely it cant be that hard to have one download area with ALL files required, including a list of sample programs to show how all the modules work. This would at leat give a good starting point.

Just before anyone says it. None of the Code from Tiny iv downloaded worked, Some of the internet code has worked but not completely as in only parts of the program work.
From my point of view I cant spend any more time on a project which is just not working for me.
But best ofn luck to u all and thanks for all the help and advice I got from you.


#9

Tell me what setup you have and what exactly you need and I will email you a working project, even call you and step you through it. What about that?

You must be overlooking something simple. Let’s try one on one and will make it happen.


#10

Hey Gus Thanks for your help.
I just wrote reply to you but lost it so now Im just too tired to go through it again.

But 2 questions for you


If you save 2 bmp images Skip and save will this program work correctly for u.
Mine wont.

Glide I downloaded it but it will not open or install. Iv tried this on 4 different computers with different operating systems.All with same results

PS Iv spent a month trying everything to see if Iv done something wrong with the setup but I cant find anything wrong.

Ill be busy for about 16 hours so no panic on replying.
Again thanks for all your help. And sorry Im so down about it but Im just not getting anywhere:(


#11

I do not want to answer questions as this didn’t seem to help. Tell what want and I will make a project for you. I need to know what devices you own as well.


#12

ok the simplest program to test touchscreen, just to let me know it works.

glide how do i install it


#13

And you are using FEZ Spider Kit? Have you tried this example C:\Users\Gus Issa\Documents\Microsoft .NET Micro Framework 4.1\Samples\TouchCalibration


#14

I dident even know there were examples there. I found them and tried 2 simple samples.
1 touchscreen
2 Touchscreen calibration

Both samples loaded and deployed with no errors.
However there was no responce from the touchscreen
I have 1 1/4 black circle in the top left hand side of the screen. But there is no responce from the touchscreen.


#15

Do you have all 4 cables from the screen plugged into the Spider?


#16

To follow on Eric’s point, double-check where you’ve plugged in the T (touch) cable from the display module. I was pulling my hair out at one point trying to figure out why touch wasn’t responding, and it turned out that I’d plugged the touch cable into the “PU Y” socket right next to the “AIT X” socket because I wasn’t reading the board carefully.

Once I switched to the right socket, things worked MUCH better. :slight_smile:


#17

Hey, Andrew, I found a picture that perfect fits for this occasion :wink:

(Can’t wait 'til Saturday)

Pete

(Don’t try this at home, kids. Andew and I have been picking on each other er working together for years. Plus, I partially blame him for me joining Microsoft)


#18

Hey! I resemble that picture.

And blame? I think the word should be “thank”.

The good news is that most of the stuff I learn, I learn by doing it wrong the first few times.

Jim, let us know if you can verify that your T cable is plugged in, and in the right socket. I’m sure one of the geeks on the forum can help get you sorted eventually.


#19

Thanks for the picture Pete. You are of course completely wrong. Which just seems to add to my first opion that this system does not work. But hey your the expert ?
So this is the best a so called expert can come up with.
Where i come from we dont call this support we call it abuse.


#20

Jim4, the picture wasn’t for you! It is a Joke between Pete and devhammer.

This is a relaxed forum and jokes come up often, nothing bad was meant by it I am sure.

Look in the replies and you will see everyone trying to help you.

@ Pete, we need clarification on your posted picture please.