Main Site Documentation

Touchscreen busted?


#1

My program may have gone haywire, but I think its electrical…the touchscreen (7 inch) does nothing, even with a simple demo test program (which always worked before). My program was working “ok” with occasional crashes, then became unresponsive at some point.

I tried reloading the bootloader & the CLR system & my code, but no luck…I am assuming this would wipe out everything 100% so its not a case of some wrong touch control register cal value sitting around, preventing a response.

The display is working fine–nice images still show up. I’ve wiggled the cables, removed/reseated them (even swapped the LCD cable ends) tapped on the board a good bit, nada. The flex from the touchscreen looks good under moderate magnification–no gaps are seen.


#2

Did you calibrate the screen?


#3

there is NO RESPONSE from touchpad…the screen images are fine
I reloaded everything possible, down to the bootloader…the demo program no longer shows any response at all.

are their restored values that might prevent the touch from working AT ALL , even after system software reloading? Is there any debugging possible? I don’t think any value is being read.


#4

Maybe values are way off?

There is a driver on code share for manual collection. Maybe give it a try.