Main Site Documentation

Touch doesn't appear to be working for me


#1

I’ve just got my FEZ Spider kit and I’m loving it!

… but I don’t think touch is working on my display.

If I run the sample code posted by devhammer over in the “touchscreen Test” thread here http://www.tinyclr.com/forum/21/4593/#/2/msg44428 my screen goes white but never goes red or blue.

I’ve updated to the latest firmware (4.1.8.0) and switched T cables. If I disconnect the T cable, it flicks back and forward between red and blue but as soon as I plug it in, nothing happens.

Is there something else I can try or is this likely to be a hardware fault?


#2

Hi Chris!

Welcome to the forums!

Does (or did) your display show any text while it’s initializing, before your program runs?

You said you had the starter kit, correct?

If so, you might also test plugging in a button to an appropriate socket, and writing handlers for the buttons Press and Release events, and try the display.SimpleGraphics.BackgroundColor = GT.Color.Red; and display.SimpleGraphics.BackgroundColor = GT.Color.Blue; lines in those event handlers, which would help isolate whether this is a touch issue or whether your screen is able to display changes at all.


#3

Chris,

Welcome to the community! I’m sorry you had to stumble across that thread right off. It’s one I think everyone would like to forget :slight_smile:

This probably has no relation to your problem but FYI - Gadgeteer sockets are not intended to be hot-swapped. Although I’ve yet to hear of this being the source of a problem, it’s not good practice and could potentially cause problems. You should power off before plugging/unplugging cables.


#4

Can you try the analog joystick on the touch socket?

Or if you are experienced, place the extender on socket T and then test the pins are functional.

Or if easier, send it back and we will check it for you.


#5

wow - quick responses!

Ian - thanks for the welcome. Re-reading my post it does sound like I’m hot-swapping the connectors but don’t worry, I’ve read that bit of the docs and I am actually powering down first.

devhammer - the display definitely works, I get text on boot-up and I’ve tried connecting a button as you suggest and caused it to draw some graphics on the screen each time it’s pressed.

Gus - I’ll have a go with the joystick & extender, I didn’t consider it might be the socket rather than the display. Unfortunately I’m in the UK (got the kit from coolcomponents.co.uk) so sending it back isn’t that easy…


#6

Hi Chris
Cool components are pretty good with RMA’s. They mixed up some parts for me and it was a breeze to swap them. Best to talk to them rather than just email though. If you can confirm that the socket is duff then im pretty sure they will do the swap especially if Gus agrees its broken.
I also noticed they have stock of the Hydra now too :slight_smile: that will be my next purchase from them at some point.


#7

I’ve tried the joystick out on socket 10 with the following code:


        void ProgramStarted2()
        {
            _lcd = new Bitmap(SystemMetrics.ScreenWidth,
                  SystemMetrics.ScreenHeight);

            button.ButtonPressed += button_ButtonPressed;

            var timer = new GT.Timer(500);
            timer.Tick += TimerOnTick;
            timer.Start();
        }

        private void TimerOnTick(Timer timer)
        {
            var position = joystick.GetJoystickPostion();

            Debug.Print(string.Concat("x=", position.X, "y=", position.Y));
            
            _lcd.Clear();
            _lcd.DrawEllipse(Color.White, 
                (int) (SystemMetrics.ScreenWidth*position.X), 
                (int) (SystemMetrics.ScreenHeight * position.Y), 
                10, 10);
            _lcd.Flush();
        }

I can get it to move anywhere on the screen, so it likes that that part’s working. It jiggles about a bit if I don’t touch the joystick, but I’m guessing that’s just the A-to-D conversion.

I’ll check the I/O pins via the extender.


#8

Right, I’ve checked the display I/O pins via the extender: 3,4,5 work fine as digital outputs so I reckon there’s something wrong with the touch output on my display.


#9

Ok then please contact your distributor for a new display module please. Maybe point out this thread too.


#10

will do, thanks for the help everybody.


#11

I’ve got my new display module - and touch still doesn’t work!

So I’m thinking that either:
[ol]there’s something wrong with the spider mainboard itself.
this is a chair-keyboard interface problem: How much force does it take to register on the screen? Do I have to run the calibration before it will work at all?[/ol]

Thoughts?


#12

This is what I was afraid of. The right thing now to get us the display and mainboard to get all sorted out.