Main Site Documentation

TinyCLR OS Debug USB Drivers not loaded


#1

Hi. I just tried connecting a G30 dev board updated to 0.5.0 TinyCLR OS version, but G30 debug drivers loading fails on my windows 10 laptop, where device manager says:

[quote]The drivers for this device are not installed. (Code 28 )

There are no compatible drivers for this device.[/quote]

…while on events tab I can see:

[quote]
Device USB\VID_1B9F&PID_0110\5&1c47687c&0&1 could not be migrated.

Last Device Instance Id: USB\VID_0483&PID_374B\066FFF565251887067061824
Class Guid: {36FC9E60-C465-11CF-8056-444553540000}
Location Path: PCIROOT(0)#PCI(1400)#USBROOT(0)#USB(1)
Migration Rank: 0xF000FFFFFFFF0033
Present: false
Status: 0xC0000719[/quote]

Any hint?


#2

Windows should load the drivers automatically but looks like a few are having this issue. We are investigating this and we will post our finding ASAP.


#3

In the meantime, perhaps you could make them available here ?


#4

@ Bec a Fuel - Did you test the one I emailed to you?

We will post here. We are testing the driver now. Sadly, windows should just work without drivers. We will still look into it but for now we will post a driver for everyone to try.


#5

Try this https://www.ghielectronics.com/downloads/TinyCLR/GHI_TinyCLR_Interface.zip


#6

@ Gus : Yes, I have tried them and they did work. Thank you very much !


#7

:clap:

It works. Thanks!