Timers are sleeping

heres why we need a simple program that demonstrates your issue. It’s been 24 hours and you took one identified issue and addressed that, but you claim to still have the issue, and you still haven’t told us what debug messages you get - netmf is good at telling you what you’ve done wrong but not listening is not smart.
You need to help us help you. Distil your code and provide a complete example that still repro’s your issue. Provide as much information as you can and watch what is happening.

1 Like

Hi Brett,

Actually, my problem has not been fixed. Timers are not working properly. I am logging everything to an SD card right now. Mike asked me a question about the watchdog. Watchdog is working with a thread timer but the NETMF timer is not stable. I am still investigating it. I will inform you when I’ll complete it.

If you really believe this to be true, then you should stop what you are doing and find another board for your project.

MF and Gadgeteer are no longer supported by GHI. If you found a bug in the firmware (low probability) it is NOT going to be fixed.

but i think most other people’s experiences are that this is a coding issue not a bug in the firmware :smile:

as I said… low probability… never say never!

Never - 10

I hope it is not a firmware bug and it is a coding issue. I am logging everything right now, the device is in my office and I’ll check it tomorrow. By the way, I have a lot of G120 devices and some device’s timers are working properly. Changing for more than a thousand boards not an easy thing for us.

You have thousands of gadgeteer boards?!

About 1500 G120 boards on the field.

1 Like

all with the same identical code in them? See, again if some are working and some are not, and they don’t have the same code, then it’s a coding issue.

I’ll go back to my original statement… your timer is being GCed and that is why it appears to stop. Hundreds of examples of discussion on the same thing since I’ve been hanging out here over the years…

Ok, I solved my problems. The first issue was the GC. GC was collecting my timer. I kept my reference and it has been solved. The second one was a coding issue. Thank you for your time and help. Maybe you can mention this GC issue on the tutorial page because I implemented my timer like your example code on the tutorial page.