The module could not be added: - A required library could not be found

Uninstalled Core and all the GHI stuff, but still with the Spider I get ‘The module could not be added: - A required library could not be found.’ when I try to add:


For the Hydra (ditto for the Cerberus of course)


Will remove everything (including all the third party stuff) and will try again.

Had some spare time tonight so I was going to build something, but now I’m just trouble shooting.

One thing about installing just the 4.2 stuff, means you can’t use the CodePlex Gadgeteer stuff as is, which means I’ll be installing the 4.1/4.2 version of the 4.2QEF2 beta GHI stuff.

WiFY support has not been released yet.

@ Mike, true Wifi support in 4.2 isn’t out yet, and some of these modules won’t work with the mainboard (ie Ethernet_JD11 with a Hydra for example), but the Ethernet_JD11 with the spider I thought should have worked and I was hoping that the camera would have worked with a Cerberus, but perhaps not. I did get a Serial Camera, but I was hoping to use that with another project (bugger should have gotten a couple maybe) and I’ll give that a go and see what happens.

I guess I’ve been running 4.2 for so long I’ve forgotten what works and what doesn’t (and rebuild my Gadgeteer setup a number of times tonight for practice, maybe some sleep would be a good idea).

Would be nice if VS could tell you if a module was incompatible rather then coughing up an error which makes you think something is missing, but…

For hardware, Always check the socket type on both ends. In designer or on website.

For software, everything is in 4.2 except wifi.

@ Gus when I’m just kicking around ideas I always start with just the designer so I haven’t gotten to hooking up hardware yet. I’m still having problems in the designer adding just a ethernet_J11D module to a Spider in a 4.2 QEF2 project (works in 4.1), has anyone else been able to do this or is there something about my setup which might be messing up?

Sounds like this explains everything