Main Site Documentation

The Debugging target is not in an initialized state Error...Please Help!


#1

Hi All,

I just received my Fez Panda board this weekend and I am having a lot of trouble trying to get an application to deploy on there.

I am currently trying to go through the starter guide and am able to get the emulator to deploy but when I try to deploy the application on the Panda, I keep getting an error stating “The Debugging target is not in an initialized state…Rebooting.”

After searching the boards for people with a similar error, I have tried just about every fix recommended but I still keep getting the same error. I have gone ahead and un-installed and re-installed my Windows .NET package and GHI SDK. I have created new projects after re-installing SDK to test. I have checked to make sure the Firmware on the Panda matches up to the SDK version number I have installed but still no luck. These are the stats I get when I access device capabilities using MFDeploy tool:
ClrInfo.targetFrameworkVersion: 4.1.2821.0
SolutionReleaseInfo.solutionVersion: 4.1.3.0

As far as the GHI package release notes are concerned, my GHI SDK package states:

Important note: Requires .NET Micro Framework 4.1 and Visual Studio 2010

• USBizi (FEZ Mini, FEZ Domino, FEZ Rhino, FEZ Panda) V 4.1.3.0
• EMX (FEZ Cobra) V 4.1.3.0, TinyBooter V 4.1.3.0
• ChipworkX V 4.1.3.0 TinyBooter V 4.1.3.0
• GHI NETMF Library V 4.1.3.0

I have downloaded and am running Visual Studio 2010 and I’m pretty sure my firmware and SDK versions line up.

Finally, I am able to ping my Panda and get the result “Pinging…TinyCLR” using MFDeploy and I have gone ahead and erased any previous code that might have been on the board using the Erase option but I just just cannot seem to deploy any new code to it.

Any ideas, suggestions would be greatly appreciated!

Thanks a ton!


#2

After you get the “The Debugging target is not in an initialized state…Rebooting.” message what happens?


#3

After I get the message, the Panda reboots and gets disconnected from the computer until I stop debugging.

Any idea what could be causing this?


#4

Are you able to upload the LED blink default application?
I must be mistaking for I do believe that the ‘The Debugger target is not in an initialized state is the normal feedback when uploading a program and not an error at all?


#5

This should be much easier so maybe we are overlooking something simple.

(as explained in the book)
Start a new “console project” which prints "hello world"
Run on emulator
change the debug target to USB and USBizi
deploy again…can your step in code?

If not, then is FEZ connected directly to PC or through a HUB? Try directly. Try to connect a power pack too if you still have problems.

…still no luck?


#6

You can also try to uninstall the micro framework debugging device from the device manager. I’ve had some strange problems with programming the panda (where it wouldn’t reprogram it anymore) and it was fixed when reinstalling the usb .net micro framework debugging driver.

Remember to change the device target in the solution if you plug it into another usb port… because it will be named usbizi(2) or something like that