Tale of woe attempting to update FEZ Spider loader

@ Brett -

Current loader version:
Current firmware version:

Both were loaded from the R2 SDK.

One other symptom - When I run FEZ COnfig | Check device for update (switch in normal CLR mode), I usually get the report on both the TinyBooter and TinyCLR, but sometimes it reports that TinyBooter is “Not present on device.” This symptom comes and goes on various machines.

@ John -

Correct. As soon as the Spider switch is moved to loader mode, the device doesn’t show up at all. Nothing serial, nothing USB, no “unknown device,” nothing at all. I’ve checked it multiple times on multiple machines.

Maybe your are also switching the debugging to serial. What switches are you moving? Post a picture please.

@ Gus -

No, switch 4 always remains in the default USB Debug position (OFF, up when viewing the board with socket 1 on the top left). In normal (EMX) mode, all switches are in the default position (OFF, or up). When I switch to loader mode, I change only switches 1, 2, and 3 (rightmost switches from OFF to ON (down), and then hit reset. As soon as I hit reset, the device is not seen at all.

I am very used to switching from normal mode into loader mode, as I did it many times when trying to get the loader updated when I first got the Spider board a month or so ago.

I don’t have a working camera at the moment, but I have double-checked that what I’m doing with the switches matches the on-screen instructions in FEZ Config and the card that is shipped with the Spider.

I am out of ideas

What about reliability of contact with the switches ? Might it be possible that it’s not really making full contact ? What would happen to the bootloader behaviour if that was floating - would it present a device or not ?

Where abouts are you physically located - you haven’t updated your profile to say. Perhaps someone with a working device and is local to you can assist ?

Well, I think I just found the new secret sauce to update the loader.

The instructions I’ve been following have always had me start with the board in normal mode, attach to the PC, bring up FEZ Config, then change the switches to loader position and reset the board. Since that didn’t work for me, I tried the following.

  1. Put the switches into loader mode.
  2. Attached it to the PC that way (no device was seen).
  3. Got into FEZ Config (which reported No device).
  4. Clicked Advanced | Loader (TinyBooter) Update | Spider, and continued through the screens without changing any switches (they were already in loader mode). When I clicked the final Next button, FEZ Config reported seeing the COM3 port and I proceeded with a successful loader update.

I then changed the switches back to normal mode, updated the firmware, and now both loader and firmware report they are up-to-date.

So, in summary, following the standard procedure of changing the switches to loader mode during the loader updater process did not work for me, but starting the whole loader update process with the switches already in loader mode (before attaching to the PC and before starting FEZ Config) worked just fine.

I’m very happy, and somewhat perplexed, but I’ll just focus on being happy with a successful update…


awesome news.

But fundamentally, that process should work the same. I always keep Device Manager open when I get weird behaviours like this, as well as having system sounds on, so I can see and hear if a device is detected. Not that it’s an issue for you now, but might be worth remembering in the future, to see if there’s any more signs there…

1 Like

@ Brett -

Thanks. Yes, I also have Device Manager visible and system sounds on.

What’s perplexing to me is that nothing showed up in Device Manager (and no sound) when I attached the device with switches already in loader mode. I brought up FEZ Config, which showed No device, and still no sounds or Device Manager entries. I proceeded as follows:

a) Clicked Advanced | Loader (TinyBooter) Update | Spider, and got the initial update screen (showing the Spider and USB Client DP module. Still nothing in DM.

b) Clicked Next, to see the switch diagram. Still nothing in DM.

c) Clicked Update, and saw the list of files populate. Still nothing in DM.

d) Clicked Next, and heard a device attached sound and the COM3 port appeared in DM.

Hope this helps. Still happy here…

Edit: I noticed that my previous post said that COM3 showed up when I clicked Update, but it happened in DM when I clicked Next on the list of files screen. I went back and corrected this.

Edit2: I’m now wondering if perhaps it just took a long time for the device to be recognized, and the fact that it showed up in DM at that step is a coincidence.

@ Brett -

Responding to your earlier post about reliability of the contacts of the switches, I did start to worry about that, after switching those things back and forth many times a month ago and this week, in my many failed attempts to get the loader updated. I wonder what the expected lifetime of those switches is.