Main Site Documentation

Super-noob questions - getting started


#1

I just got a FEZ Panda board, I have VS2010 with NETMF installed. I installed the GHI USB drivers and put the latest firmware on the Panda (4.1 something I beleive).

I’m a seasoned .NET developer, I’ve done some hobbyist-type stuff with sensors (using Phidgets), but I’m new to NETMF.

I checked out the samples, but couldn’t really find one that did the basics. I don’t have any input or output at the moment, so I just want to, in code A) see if I’m running in an emulator or not and B) get some basic information about the system/board/firmware/etc. Just using intellisense and trying different things, I get InvalidOperationException with just about everything I try using the emulator first.

Anyone have any good resources on how to start off with some basic output of some useful information about the current environment?

Also, I tried to add a reference to FEZPanda_GHIElectronics.NETMF.FEZ because I assume this is going to have some Panda-specific functionality, but this blows up when I run it via the emulator.

How do you make an emulator that acts like a Panda board?

Signed, the Newb - thanks!


#2

Welcome to the forum.

We have some resources that will help you started:

Free e-book:

http://www.tinyclr.com/downloads/Beginners%20guide%20to%20NETMF.pdf

Beginners Tutorial:

http://www.tinyclr.com/downloads/FEZ_Tutorial.pdf

There is more info on Wiki as soon as it is up again.


#3

yeah welcome Rob.

The emulator will always complain that you don’t have a Panda attached if you attempt to deploy to it with the FezPanda_GHI(blah) reference added. That you can ignore. But if you attempt to reference stuff that only GHI add, then you’re not going to get much further - there really isn’t a complete method to do that (actually someone was working on emulating a Fez, did that go anywhere?).

One book I have bought that I found valuable was Jens Kuhner’s Expert .Net Micro Framework (I have the 2nd edition, found it for ~$20 new on ebay). It covers a wide range of topics and not just at Expert level but was really good at helping understand some of the basics too - but the beginners guide as Architect points out is also invaluable !


#4

Architect - thanks, I’m digging into those now.

Brett - I did order that book, in fact it’s supposed to be delivered today.

Thanks for the quick responses, I’ll continue to dig in!


#5

Let me run one more thing by you guys. I have a simple program:


public static void Main()
{
    Debug.Print("Manufacturer: " + Microsoft.SPOT.Hardware.SystemInfo.OEMString);
    Debug.Print("Version: " + Microsoft.SPOT.Hardware.SystemInfo.Version.ToString());

    Thread.Sleep(2000);
}

I run it in the emulator, it works fine. I bring up MFDeploy, my Panda responds to a ping. So in VS2010, I choose USB as the deployment option and “USBizi_USBizi” as the device.

When I hit F5, I only get:

[quote]------ Deploy started: Project: MFConsoleApplication3, Configuration: Debug Any CPU ------
------ Deploy started: Project: MFConsoleApplication3, Configuration: Debug Any CPU ------
An error has occurred. Please check your hardware========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========[/quote]

and for deployment output:

[quote]Incrementally deploying assemblies to device
Deploying assemblies for a total size of 189928 bytes
Assemblies not successfully deployed to device.
Deployment to the device was not successful.[/quote]

Any ideas why this doesn’t work? It should be this straight-forward, right??


#6

Try different usb port/cable.

Edit: Total size is suspicious. Start with empty project.


#7

189928 bytes?! WOW what assemblies have you added? :slight_smile:


#8

@ Gus. You are the fastest again! :smiley:


#9

Ha ha…it is a race Architect…bring it on my friend! :slight_smile:


#10

Ahh - that was it! Yeah, this was a project where I was messing around with all sorts of ideas. I started with a fresh project, now I get:

[quote]Deploying assemblies for a total size of 7408 bytes
Assemblies successfully deployed to device.[/quote]

And sure enough, it ran - I deployed my first project, thanks all!


#11

Congratulations! You just made first step in becoming a FEZ zealot! ;D ;D ;D


#12

@ Rob, stay tuned for some extensive tutorials in the making!