Strange Happins' at my Spider playground!

I have been using a application for my Spider that communicates with my Android Tablet. In fact I just posted some code of this application yesterday.
(I think it was yesterday) Anyway, it was ‘really working’ … Honest it was!

But not now??? I have no Idea what happened and I have not been able to find the solution.

In fact I erased EVERYTHING related to .NET Micro from my computer (Including C# Express and SQL). I started over from scratch (What a pain!).
Reflashed the Spider firmware to the current 4.2 (Same as I had been using before)

Maybe somebody has an Idea… Sure hope so.

Partial code:

       void StartWIFI()


            if (!wifi_RS21.Interface.NetworkInterface.IsDhcpEnabled)

            wifi_RS21.Interface.WirelessConnectivityChanged +=
                new WiFiRS9110.WirelessConnectivityChangedEventHandler(Interface_WirelessConnectivityChanged);
            wifi_RS21.Interface.NetworkAddressChanged +=
                new WiFiRS9110.NetworkAddressChangedEventHandler(Interface_NetworkAddressChanged);
                WiFiNetworkInfo[] ScanResp = wifi_RS21.Interface.Scan(ssid); //The Spider resets/reboots here
                // ^ On the above statement the Debuggable .Net Micro Framework Device driver ^
                // (GHI .NET Micro Framework USB Debugging Interface) disappears in the Device manager
                //Use to Scan for all SSID's
                //WiFiNetworkInfo[] ScanResp = wifi_RS21.Interface.Scan( ); 

                if (ScanResp != null && ScanResp.Length > 0)
                    //Your passkey needed here
                    wifi_RS21.Interface.Join(ScanResp[0], PassKey);

                    if (useDebug) { Debug.Print("Connected to Wireless network - " + ssid); }
                    if (useDebug) { Debug.Print("Failed to connect to Wireless network - " + ssid); }
            catch (Exception e)
                Debug.Print("!!Exception : " + e.Message);

            ipep = new IPEndPoint(IPAddress.Parse(ip), port);
            AndroidSocket = new Socket(AddressFamily.InterNetwork, SocketType.Stream, ProtocolType.Tcp);

At the code statement

WiFiNetworkInfo[] ScanResp = wifi_RS21.Interface.Scan(ssid);

The Spider resets/reboots because the GHI .NET Micro Framework USB Debugging Interface disappears from the Device manager.

I am using Windows 7 64 Bit and have used the code many times without problems.

How are you powering your system?

Sir… GUS

How are you powering your system?

I am using a powered USB Hub. I have three and tried them all. When I received the error I was using the powered USB hub that was being used when the app. was working.

I ran the application many times over approximately a week without any errors? I have no idea what happened. When creating the code my only problem was finding out that I needed a delay between creating the Socket object and connecting to the socket.

I never had any issues scanning for SSID’s. I can find about 20 around where I live. (Or at least use to be able to).

Can’t get my mind around the USB disconnecting when starting a Scan…

You question… Made me think of trying to power the WiFi off of my Lab Power supply. I know that I had to use Aux power with my WiFly GSX (Roving Networks)…


Not sure what to say except that it does not appear that the problem is related to my code or the GHI drivers.

I installed a Extender 1.2 between the Spider Socket 6 and the WiFi RS21 and BINGO… It connected to my Android!
I was going to check voltages and I had connected my Oscilloscope to the Extender Ground and the 3 Volt pin to take a voltage reading.
I reset the spider and I was off and running… ???

Voltage measured was 3.18 VDC and 4.87 VDC (Using a powered USB Hub)

Adding extender fixed the problem?!


Adding extender fixed the problem?!

Lets just say something changed…

I really have no idea what, if anything, changed.

While I was having the problem I had removed and re-seated all of the connectors but it still failed.
It is working now without the Extender…

I did have 10 software updated from Microsoft since it was not working and now. All related to .NET Framework 4 but I doubt that had anything to do with it.
It was working before the updates and before the problem showed up.