Main Site Documentation

SPI MOSI is high leading up to a Read on CerbuinoBee. Is that right?


#1

I am communicating with the TI CC3000 over SPI. With other NETMF devices, it works. But on the CerbuinoBee (firmware 4.2.0.5), it does not, returning nothing but 0x04’s. The first SPI message seems to be sent and accepted. But that is followed by an interrupt signal and an SPI Read which gets a response that is bad. The only difference I see in my logic analyzer is that MOSI is high leading up to the Read. On the other NET MF devices, on my Stellaris Launchpad, and according to TI docs, this is not normal.

Attached is the logic trace I captured from the CerbuinoBee (top) and the trace provided by Texas Instruments (bottom) with the offending signal marked with an arrow.

All this is very repeatable. It does this every time on the CerbuinoBee. What I don’t know is if this is “in spec” but the TI device is being picky or if this should be low, or perhaps there is a setting I missed.

Any experienced SPI folks with any thoughts?


#2

OK, I added an in-line resistor of 150 Ohms to MOSI and MISO and it is working perfectly at the moment. It looks like MOSI being high when idle does not actually matter.


#3

Did you try to lower the clock speed?


#4

Is there a chance that the SPI mode is different on this device?

Could this be the reason for the failure?


#5

Gus-- I had already tried a slow clock speed, no change.

Dave-- Yes this chip does use CPOL but setting the SPI to use it actually seems to make things worse…

Adding the resistors worked flawlessly, running 20 hours straight now. So, I think it must have been related to the voltage range?