Main Site Documentation

Some problem about G120HDR


#1

Dear friends
i am a new player of this kind of board.
I downloaded all the program and connected the board with PC. all things were OK.
then i updated the board to 4.3 version.
after updated, the board can not be identified by the computer. I use win8 OS, and GHI program 4.3 version.
Now when i connect the board to the computer, sometimes it shows couldn’t identify the device.
some times it shows G120 and when i try to ping the board by FEZ config, it shows Failure - Device is not connected or not responding. and the deceive become not be identified by the computer.
The three figure shows some state of my computer and the board. the board change state from identified or not fount or can not identified automatically even if i don’t touch the USB line.
can some one help me ? this is for my graduate thesis . : (
thanks all


#2

Welcome to the forum!

Take a deep breath and relax. you will get lots of help here.

To begin, have you looked at this document?

https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting


#3

thanks for your reply. ;D
i read a part of documents. But i am not English mother tongue and with poor English.
So i can’t understand clearly of this. And i want to know if i destroy my board or how can i fix it


#4

@ Brett -
Sorry for trouble you bro. Actually i am a mechanical engineering student. And my tutor gave me this strange topic of thesis about city car monitoring. XD
I searched some old posts about the similar question which you solved for others.you are so professional about software / hardware field. I also check the the device manager any try to use your previous solutions. But this is the first time i use this kind of board and i even don’t recognize all GHI programs.So i don’t find the way to solve this question.
The question is similar with a two years ago post about miss USB connection of a panda II board. and your solution is
"Open Device Manager.

With nothing connected, in device manager you should not see anything about a Debuggable .Net device. You should also NOT see any extra COM ports other than what your usual machine gives.

Plug in the Panda. It should recognise your device and show it as a Debuggable .Net device in device manager.

Unplug it again. Device manager should make it disappear.

Hold down the LDR button and then plug it in. You should see the GHI Boot Loader interface pop up as a COM port. ."
But there is no LDR button in my board : (
I think the driver is ok, because at first, i plug in the device all things are ok, and i can also check the program inside the board which is finished by my friend. But after i update it to 4.3 version. The problem occurs. And i try the process in a new GHI board. It is the same result.
Do you have any other way for this question ? Now Both Fez config and .NET micro frame development tool are miss response of my board.


#5

Yo Bro !

Sorry, couldn’t resist.

Sorry, Panda is different to G120HDR. There’s some things that are pretty different from netmf perspective, and many things have changed in the drivers, so I’d suggest like Mike says and step thru the troubleshooting guide - in particular, in the sections “USB Driver problems (overview)”, “USB Drivers (Loader mode)”, and “Problems with USB and MFDeploy or FEZ Config”. Let us know what you find through that, and check the driver properties pages for the drivers at each of those points


#6

@ Brett - Hi bro
i have read the guide, but didn’t get any points. For my device manager, when i plug in the USB, sometimes it shows G120 and sometimes it shows unknown device. And i can be switch between these two states automatically again and again even i don’t touch any thing. and it don’t have any response in neither two states. i shows the states in the picture
I have both Winusb driver and GHI_NETMF_interface driver. device manager shows Winusb driver when the device can be recognized. So should i let it use GHI driver? how ? i tried to delette Winusb driver, the windows system forbid this action.
thanks a lot, i am a really noob of computer :frowning:


#7

fundamentally, if you have the device connected and it appears and disappears without your involvement, then you may need to look at power and the USB cable. I would replace the cable with another thicker cable to see if that is causing you an issue, and check the fitting of all cables between the HDR board and usb. The correct/expected behaviour is the device appears in Device Manager and be stable there unless you reboot it or remove it.

Can you confirm if you ever loaded your code on the device after you upgraded the firmware ?


#8

Sounds like you may not have updated the boot program on the G120HDR. The early models don’t have LDRx buttons, you have to short P2.10 and P0.22 to ground to get the G120HDR into boot update mode. This is explained in the G120 user guide.
Make sure you have done that first or you won’t have any success.


#9

@ Brett -
no, it won’t disappear.just shows G120 or unknow device. i change another USb cable, it is the same result. I think the cable is ok, cause all problem begins from i upgrade it.
And this board is not a new board. Some previous student use it to do a OBD device, and it works well. when i get this board, it also works well.
And after i upgrade, the board can not communicate with the computer, so i never load any code after upgrade


#10

@ Lurch - @ Brett -
yes, i think maybe you are right. I get this board from previous student. P2.10 and P0.22 connect with other points(i think connect with 4 and 5 ). i show the connect in the picture. So should i disassembly these two connect ? and make two new cables connect P2.10 and P0.22 to the ground ?


#11

Those pins (P2.10 = LDR0, P0.22 = LDR1) have internal pull-ups and LDR1 is already correct (Gnd), so you just have to unsolder LDR0 from pin 4 (3.3V) and connect it to Gnd, then reset to get into booter update mode. Instructions for the update are in the “G120 SoM User Manual” which you can download from the top of the Support->Documentation web page. Read that before you do anything else.
Remember to unhhok LDR0 from Gnd after the reset - it’s just needed during the reset.
When you are done, you should consider leaving LDR0 unsoldered, as P2:10 has pull-ups.


#12

@ Lurch -
Hi dude, you are right. i reset the board and update it again. now all things are ok ! thank you !
and another thing, how can i find G120 HDR in the toolbox in VS2012 ?


#13

You could use the Cobra Eco in Gadgeteer - it uses the G120 module. Of course, some stuff is missing, but then the G120HDR only has a couple of real sockets.
User TaylorZA made a G120HDR Gadgeteer installer for 4.2, but it’s not updated for 4.3. You could search for his 4.2 version and rebuild it for 4.3. IIRC, he wrote up a method for doing that.
I just use plain .NETMF for the G120HDR, so I can’t help there.


#14

@ Lurch -
OK, i understand, thank you very much for your help.
and i do this follow a thesis from a previous student.
There is a picture in his thesis. i show you in the file.
He use VS 2010, and there is G120HDR in the toolbox. Do you know how did he realize this ? Use taylor’s installer ?
At the beginning i use 4.2 version and VS2010. But the GHI website show me if i want to use the updater i must download 4.3 version and VS 2012. so i change all program.
It seems too hard for me to understand all of this with a zero fundamental of electronics :’(


#15

@ Lurch - @ Brett - @ Justin - @ Gus -
Hi dudes, i found a 1 year ago posts.https://www.ghielectronics.com/community/forum/topic?id=12508&page=2
And i download a small program made by Justin. Now there is a G120HDR board in my VS 2012. It seems well, But i need to test if it is useful in the VS2012 and 4.3 version in the lab tomorrow. cause the board is left in the lab.
And i also don’t clear about the pin map of this board. could you give me some advice ?
For example, i have a display TE35 How can i realize to show some picture in the display through G120HDR ?
And i have another cellular radio for my project. My professor buy it for me(actually i am an automotive engineering student without electronic knowledge. My professor said this is the basic of vehicle long route communication. But why did he choose me to do it ? i am major in chassis design :smiley: :D). which pin should i set for the cellular device ?
My final purpose is that : read the information from vehicle CAN bus(for example Engine RPM etc) and transfer it to cellular signal . then sent a message to my phone.
And another question is founded. when i try to add cellular radio in the VS2012 it show this hardware currently not usable. it can only use in micro framework 4.2. So it means i must use 4.2 version ?
thanks all for you kindly help :stuck_out_tongue: