Main Site Documentation

Some issues that came up trying TinyCLR OS


#1

Hi

Like the idea behind TinyCLR OS but seems there are some issues yet. I am using Community VS 2017 on Windows 10. I have a .NET Micro Framework program running fine on a G30 TH module. Redid the program as a TinyCLR project. Debugging abilities is one of the biggest reasons to use a platform that can be programmed with VS. I was finding running on the G30 the first breakpoint would work and stepping into would work but if Continue was tried seemed like the program was being restarted and I get…

Looking for a device on transport ‘USB’.
Found device port ‘USB’ with ID ‘686db267-b4f4-417c-b612-558d0251492f’ for transport ‘Usb’.
Starting device deployment.
Attempting to connect to device ‘USB:G30’: iteration 0.
Opening port '\?..port
Attaching debugger engine.
Debugger engine attached.
Querying device assemblies.
Found assemblies:
- TinyCLR00 v1.0.0.0.
- mscorlib v0.5.0.0.
- GHIElectronics.TinyCLR.Devices v0.5.0.0.
Generating device specific assemblies.
Deploying assemblies:
- TinyCLR00 v1.0.0.0 with size 9,568 bytes at '…file
- mscorlib v0.5.0.0 with size 76,636 bytes at '…file
- GHIElectronics.TinyCLR.Devices v0.5.0.0 with size 39,492 bytes at '…file
Total deployment size is 125,696 bytes.
Incrementally deploying assemblies to the device:
All assemblies on the device are up to date. No deployment was necessary.
Restarting interpreter.
Attaching to device.
Waiting for device to initialize.
The debugger engine failed to receive any debug events from the debugging target

Also some code in the .NET micro platform that used a method referenced by type name keeps getting a null reference exception even if the exact same code was fine under NET micro

Gus50310


#2

Sounds like you have power issues causing the device to rest. Try a powered hub, a shorter USB cable, different USB port.

Even try a different PC. Debugging works flawlessly on the few machines I have tried.


#3

Thanks for the quick response Gus…I’ll try the suggestions…Gus50310


#4

Gus
On my computer I found that the 2.0 USB ports seemed to work fine while the 3.0 USB ports did not play nice in debugging. Also my bad in that I did have a slight code translate mistake in going from .net micro to TinyCLR that once I fixed TinyCLR on the G30 module worked just fine including the SPI functions.
Still hoping to find some way to at least make it harder for the uninvited to get at the code.
If you have any suggestions or questions please let me know…Thanks
Gus50310