Main Site Documentation

Solution for signature file check failure


#1

I have a strange problem with being able to deploy a hex file onto the EMX. Everytime I try to deploy a file I get the error Signature Check failed.

I first installed VS C# 2010, then the .NETMF 4.1, then the GHI 4.1SDK. I loaded the CLR, CLR2, Config files onto the EMX module without a problem.

I await your response.

Thanks,


#2

Enter GHI loader (hold up down and select) then erase all using E command.


#3
  • I viewed the video but I do not have the FEZ board. I ahve my own PCB with both USB host and device connectors.
  • I plugged in the USB device connector and then reboot the module while holding down Up,Dwn&Enable. The result of that was Windows XP found an unkown device.
  • I have tried installing the driver from the said location c:\Program Files\ …\GHI_Bootloader Interface but Win XP will not allow me to install it stating these drivers do not represent the hardware connected.
  • Do I have the correct hookup ?

#4

If you held the buttons properly then windows will ask for drivers


#5
  • I used a different PC and managed to succesfully install the drivers.

  • I used TeraTerm downloaded from your website to connect. The very first time I pressed “V” I received the following response
    1.02
    BL
    I pressed “V” again and received the following message
    BL
    I pressed “X” and received the follo.
    BL
    It seems all the commands return only a BL.

  • I then closed TeraTerm switched power off and restarted in GHI bootloader mode. Now every command responds with a BL.

  • What should I try next?

  • Why is it doing this ?


#6

Your terminal is sending extra characters, most likely it is appending LF to every CR. Disable that and all will work fine. We highly recommend you use the terminal from our website


#7

That worked. Thank you very much for your support.

Regards,


#8

@ Gus … I don’t know whether this need’s looking into. I’ve seen quite a few cobra’s on these forums having problems with driver install for the bootloader… It appears that some USB ports are not really strong enough to see the board when in bootloader mode… I have, (as you probably know ), quite a few FEZ boards and I have tried them on all four of my workstations. My main development computer has a very weak USB power supply and will not see 3 of my FEZ boards both Cobra’s and one Panda… With my new 10 port hub there is no problem. The USB ports work ok under deploy and debug but seem to need a bit more power in bootloader mode.

Cheers Ian


#9

The larger the boards, the more components it has the more power it will need. We always use powered HUBs.
Most users out there have a little “cheap ebay” hub with many devices connected and work fine but those devices (mouse, keyboard…) draw very little power. Try to plug in an external hard drive and it will probably not work.

Of course anyone can use a power pack to power FEZ instead of relying on the USB power.

Now to loader vs firmware, I am curious so I will get the amp-meter and run some measurements