Main Site Documentation

Software Confusion


#1

I’m relatively new to .NET Gadgeteering and the .NETMF so if this post is misplaced, I apologize.

I have Windows 7 64 bit with plenty of ram and a i5 CPU.

I have access to Visual Studio 2010, 2012 and everything in between from DreamSpark via my university.

A week ago I was trying to load programs onto my Cerberus.

I followed the steps at the Support tab above and first I downloaded and installed Visual Studio 2012 Ultimate.

I installed the following softwares and it didn’t work. I scoured the tutorial about updating the tinybooter then the firmware and it worked but it told me that Visual Studio was trying to use 4.3 and my firmware and booter was 4.2.

I decided I needed to use Visual Studio 2010. So I restored my computer to pre VS 2012 and downloaded 2010 Ultimate from DreamSpark. I don’t know what was wrong with my download but I couldn’t get it to work for the life of me.

So I gave up and installed 2010 Express, followed the Support steps, updated the tinybooter and firmware and voila! It was working and loading programs.

Then I find out there’s a trial period on my 2010 Express which is irritating so I downloaded 2010 Professional. It FINALLY installed after hanging for 20 minutes.

I tried to open the file I was working on and it said “The project type is not supported by this installation.” Which is confusing.

So I decided I would go back to the support page… except it’s different now.

Now it only recommends downloading VS 2012 but the Gadgeteer Package only makes mention of SDK 4.2.

This is confusing because VS 2012 works with SDK 4.3 but the Gadgeteer Package seems to only support 4.3.

I’m really confused and I would greatly appreciate some guidance or list of steps to make this work.


#2

You are on track. You should define the version of your project build to be 4.2, but use the 4.3 package. The core Gadgeteer library is still 4.2, but some stuff in the SDK is 4.3 to support VS2012.

Go ahead and use 2012, but define your version for the project to be 4.2.


#3

@ Keith unfortunately a lot of unnecessary work.
As njbuch mentions, there is a properties page where you set the Framework version of your project. See the image below as an example
The Wiki is being constantly improved, so feel free to make suggestions that could help beginners.


#4

Well that’s embarrassingly simple.

To whom should I forward a recommendation for revision (assuming the step you suggested isn’t there and I simply missed it.)


#5

@ Keith_ - The 4.2 versus 4.3 issue is covered in the following document:

https://www.ghielectronics.com/docs/21/first-netmf-project

[quote]Tip
If you don’t see the assemblies you expect, make sure your target framework is correct (Project->properties menu in Visual Studio), in the following screenshot the target is set to 4.2. Targetting a newer .Net Micro Framework (say 4.3) with an older SDK (say released for 4.2) will not work. Although targetting older Frameworks is supported with new SDKs, we strongly recommend matching your target to the SDK.[/quote]


#6

I see. That’s a rather important detail that I didn’t understand when I read it the first time.

Perhaps it would be better to point this out and make it seem like a big deal on this page?

https://www.ghielectronics.com/support/netmf

Thank you much!