Main Site Documentation

Serial Debug over XBEE


#1

Hi there,

I have a Panda II and I’m experiencing some problems.
My ultimate goal is to do serial debug from VS using an xbee shield.
My shield works fine because when debugging over USB I can send and receive data to the panda’s COM1 with my xbee.
When I start the panda in debug (with the mod jumper) I can read lots of data comming from the panda. But when I try to debug or even ping from MFDeploy I have no response from the device.

Maybe my xbee doesn’t have the right parameters for MFDeploy. Currently I have :

  • 115200
  • no flow control
  • no parity

I’ve search the forum but with no luck. Did I miss something ? Has anyone tried this before ?


#2

This should be possible in theory but was not tested on xbee. I know someone was able to do this over bluetooth.

Can you ping your FEZ from MFDeploy?


#3

No it doesn’t ping. Everytime i press ping, it gets stuck until I have a “Error: No response from device” or “NoConnection”.
And what about the settings of my xbee ? What are the settings of MFDeploy concerning Serial com, I know it’s 115200 for the baud rate but what’s the settings for the parity … maybe it’s the problem ?


#4

Your settings are correct.


#5

Try testing a lower baud rate. Start at 9600 and work your way up (if that works).


#6

You can’t change the baud for debugging! I did ask fro this years ago BTW but it is locked for 115200


#7

Good to know. I’ve actually never tried, but assumed you could.


#8

I don’t know anything about XBEE, so please excuse my ignorance.

There are a few possible problems.
[ol]What is the air speed of XBEE? If you send data at full speed, without handshaking, does some of the data get lost? IE, is there a buffer overflow? This is possible if the data rate over air can’t keep up with the serial port speed.
What is the latency for XBEE? IE what is the delay between sending data and getting it on the other side. Some radio modules try to collect as much data as possible before sending it. This might be a problem if the delay is too long. See if it can be decreased via a command to the XBEE.
[/ol]

That port speed on the XBEE is non volatile, right? You don’t have to send a command every time to set it’s port speed?


#9

Well, I can’t figure out what’s wrong.
I checked my XBEE settings to be sure that data is sent as soon as I get it. I can use the MFDeloy “connect” function and see all the debug messages when my Panda II boots up, but ping doesn’t work and I can’t deploy from VS.

I’m running out of ideas here…

Thx anyway guys,


#10

Try if you can talk to your usbizi board using the pc.
If you can send data you are at least sure that the problem is not in the xbee configuration.


#11

Already done that and it works perfectly fine, that’s the worst part. Bytw .NET MF is so cool for that, event handlers are so handy.
I also tried on different computers and got the same result. I think I’ll try to re update the firmware and test with one of my friends’ board.