Main Site Documentation

Sending raw Ethernet data with J11D Module


#1

Hi there,

I have a Spider Starter Kit and the Ethernet J11D Module. I try to send raw Ethernet data without using the TCP/IP-Stack, e.g. a single ARP Request.
Is there a way to do this?
So how to send simple layer 2 based data?

Thanks in advance!


#2

@ andre.m -
andre.m, thanks for your fast reply.
But as I understood the socket comes from system.net. But I don’t have this assembly, not in the netmf. I reinstalled everything but I cannot find it. Is there something special I need to do?

Thanks in advance!


#3

Yes, I am sure that I am using 4.2 with Visual Studio 2010.
I tried to select and import it from the NETMF Directories, but there is no system.net.
the only one I can use is “GHI.Premium.Net


#4

yes, it should be in system.net
I checked allready microsoft.spot.net but there it isn’t.

regarding system.net, I searched complete C: but no result for the netmf.

ok, so I try to figure this issue out

Thanks for your support! At least I have a starting point :wink:


#5

yes, I know. But the problem is there is no system.net. I am using also system; but also in there is no .net.

This is my problem and the reason I tried to find the assembly on C to integrate it.
The only assembly I can find is System.Net.Security, nothing else


#6

The image shows the possibilities I have


#7

Yes, I can use Microsoft.SPOT.Net; but in there is no Socket.
The attached figure shows the example from “Networking” I cannot run this because Visual Studio can’t find System.Net.


#8

@ sabrina.hein - Try adding reference System.


#9

OK, I don’t know why but it is there now! System was all the time in my references, I used it allready (?) I deleted it and added it again and now it works! Can’t believe…

Cool, thanks for that! It helps me a lot!

Best regards


#10

@ sabrina.hein - I’ve seen things like this before, but I’ve always attributed it to old age! Probably not the case for you!


#11

This usually happens if you open a project targeting an older framework, and Change it to a new framework… if you do delete and reference everything, or better yet start a new project and copy and past your older code into it.

Jay


#12

yes, I’ve done something in this way.
Normaly I test deleting and reimporting, but at this time I was so focused on the other point that I forgotten to try…

Now I am back to the old problem: sending raw data like an ethernet frame.
I only want the socket to send my bytes. But my data is always packed in an IP-Packet. I tried allready different addressfamilies, protocoltypes. Nothing works fine.

Is there any idea solving this issue?

Thanks in advance!


#13

Share your code please, so we can help you better …
don’t forget to use Code Tags :wink:

Cheers,
Jay.


#14

Hi there,
sorry I had no chance to go on with this issue.

So I can show the code, but there is not much.
Only the new Socket Instance with AddressFamily.Datalink, SocketType.Raw, ProtocolType.WhatEver

As I guess I need a way to create a Socket without the Protocoltype, because the Protocoltype always references a IP-specific Protocoltype. But I do not need this, because I only want to use Ethernet.

Any idea for solving this?

Thanks in advance!