Main Site Documentation

Send Email


#1

I have a FEZ Panda II with the connect shield. I have copied the “Internet of Things” email door monitor. When I go to upload it to the board it times out. I have uploaded other code to the board so I’m sure I can connect to the board. I can post the code if necessary but it is a direct copy from the tutorial. Any suggestions?

Thanks, Mwao


#2

Welcome to the forum!

Do you mean uploading from visual studio?
Have you updated the firmware?


#3

Thank You!

Yes from VS2010.
Yes I have updated the firmware.

I can upload a simple code to turn the onboard led on/off with the onboard button. That all works flawlessly.

So I stepped up a few tutorials and am trying “http://wiki.tinyclr.com/index.php?title=FEZ_Email_based_Door_Monitor”. I copy the code word for word and go to deploy it. It acts like its deploying then I get a Unable to Communicate with USB:USBzi. I can go back to the simple code and it uploads fine.

Hope that helps…


#4

I have added a picture of the error. The code was straight from the tutorial. In this test I have modified the IP to be static instead of DHCP.

Only other modification is to change the test email address to my own.

-Mwao


#5

Any other messages in the output window in vs?


#6

sometimes this type of error can be indicative of the previously loaded app not relinquishing CPU time for the debugger; if that is the case (and I don’t know it is for you!) you can usually hit reset while its deploying and it responds, try that.

Can you also confirm what SDK version you have and the firmware version - I’m sure we trust you but well, perhaps I don’t :slight_smile:

The other thing is that MAC addresses can be weird; try a random one from http://www.macvendorlookup.com/ and see if that changes the behaviour?

I assume this is your very first Fez and your very first foray into networked items?

Final thing for now - do you have the ethernet (if you’re not using a shield) connected correctly, as the code expects? Perhaps show pictures of how you have it all connected. I can’t imagine things would behave this way if it was not connected properly but weirder things have happened…


#7

I’m running Firmware Version: 4.7.1.0
Not sure how to check the SDK version. Let me know and I’ll check that.

This is my first foray into Fez, but not my first foray into networking by any means.

But it is now working again. Not sure if your first assumption was correct or not, but I tried to do a get version for the firmware and it said I had two devices connected. I rebooted, got a BSD with error about USB, rebooted again and now I am able to load code to the board again.

Thank you for help. I will look up a new mac address, that one was just copied from a tutorial i found somewhere for networking w/ Panda II.

As side note, I can ping the board at the given address, but the email code is still not working, but at least I can upload new code to troubleshoot. =)

-Mwao


#8

“C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\GHI NETMF v4.1 Release Notes.rtf”


#9

hi
i am having trouble uploading my program to fez panda iii board.my pc has detected the device as G80 but as i debug the program a dialogue box appears showing deployment error and in the output window it is showing that the device cannot be opened.can you please tell me what might be the problem and how to rectify it.please help me i am very much new to this device as well as programming.


#10

I think you posted this question twice. Please do not repeat the same question.