Main Site Documentation

SDK Version 1.0.16 with WiFi Enhancements and Native SoftwareI2C


#1

The new SDK is online which includes Software I2C which is needed for the upcoming Gadgeteer SDK. The SDK also includes new support for RedPine WiFi modules. Please see release notes for further details. http://www.tinyclr.com/release-notes/


#2

Just saw the news in my outlook :smiley:
Cool! Now some free time ::slight_smile:


#3

Update time!


#4

Any code examples to get her running ?


#5

Look in the SDK documentation. There are some great examples.


#6

Updated a Panda and two Panda-IIs. Everything still runs! ;D


#7

I’ve installed the new 4.1.7.0 firmware in my Cobra.

I’m able to load and run the calibration applcation listed in the Help documentation, but the Glide examples are no longer working.

I tried removing and then re-adding all SDK and Glide references. The example application #3 downloads and begins to run, but then it throws a ‘System.OutOfMemoryException’ on this line of the code:


		public static void Main()
		{
			// Load the windows
			windows[0] = GlideLoader.LoadWindow(Resources.GetString(Resources.StringResources.window1));
			windows[1] = GlideLoader.LoadWindow(Resources.GetString(Resources.StringResources.window2));
			windows[2] = GlideLoader.LoadWindow(Resources.GetString(Resources.StringResources.window3));
			
			// Activate touch
			GlideTouch.Initialize();
			

I’m getting similar errors in other Glide example applications.

Any suggestions?

Thanks.


#8

Is my problem due to the fact that the Glide DLL was compiled with a previous version of the GHI libraries? If that’s the case, is there a date set for when Glide will be updated?

Thanks.


#9

Possible but glide doesn’t use any of the GHI libs. You can tell by looking at the assemblies added to your project. Maybe the example uses them for something else?


#10

I updated my EMX to V 4.1.7.0 and ran the multiple window example without issues.


#11

Thanks Gus and Josh.

It must be something I did wrong. Tonight will wipe out the project and start again… I’m sure it will work okay.


#12

Is the schematics of the WiFi board that uses the Redpine module available anywhere ?


#13

Not yet but all will be online in very near future


#14

Why we cannot use the Wifi class with the FEZ Panda II ?
I want to use it with the redpine signals module but when I tried to compile and run it on the board, I get an “unsupported” exception. I saw on your website that it’s release just for Chipworkx and EMX, but why ? The IP stack is managed on the Panda and the ARM is the same.


#15

9+MB versus 64K of memory? Plus a lot more flash on ChipWorkX and EMX module.

On the W5100 based boards the IP stack in the chip, and limited to 4 sockets.

On the ChipWorkX and EMX module the stack is on the module and you can have about 128 sockets.


#16

But why I am able to download an example on the panda ?

If a program is too big it will not run right ? Because I can run it and the exception appears when I try to use the Wifi class.


#17

Your program is calling library functionalilty that is not implemented on your device. That is what is why you are getting an unsupported exception.

The firmware on the Panda has stubs for the unsupported classes, which return exceptions.


#18

Ok I see. So when I add a reference in my project it will not be copied on the ARM. It’s just my code that is copied and all the framework is already in the chip with USBizi, am I right ?


#19

yes! :smiley:


#20

Ok, I get it. Thanks for your answers ! :wink: