Main Site Documentation

SDK 2013 R2 and FEZConfig Potential Issue


#1

Using FEZConfig to set LCD parameters or Ethernet MAC address on a EMX Dev System results in loss of firmware.

I first loaded the R2 SDK using FEZConfig and everything went well.

With the new R2 firmware, the LCD is not configured by default. Remembering a recent suggestion by Gus, I decided to use FEZConfig to setup the LCD on the dev system. I first downloaded the setting for the LCD from the board, and then set the values used in the T35 display. I then uploaded the setting to the system.

I then reset the board, and the TinyBooter information appeared on the screen. When I looked at the device capabilities I saw that the firmware was no longer present. I tried reloading the firmware and setting the LCD several times with the same results.

After loading the firmware again, I used the program included in the T35 document to set the parameters. After a reset, the correct firmware info was displayed on the screen.

I then tried to set the Ethernet MAC address using FEZConfig. Boom, the firmware disappeared again.

I don’t know if this is a FEZConfig or a R2 issue. Or an interaction between them.

I downloaded the lastest version of FEZConfig from the support site today.


#2

Are you sure you have the latest tinybooter loaded?


#3

@ Gus - 4.2.10.0 . I did not update the tinybooter from the last SDK.

if I don’t use fezconfig everything works fine.