SD Card Initialization issue

Ok, I have added a 100uF cap over the powerline as close as possible to the sd socket, but things still don’t work on my panda I. The Cobra is reading/writing the same sd cards just fine.

Is it possible to connect the SD card adapter to the Cobra in order to exclude a HW fault? If so, how should i connect this. The SD card adapter is home made like explained in the wiki http://wiki.tinyclr.com/index.php?title=SD_Card_Connection_Guide

As I couldn’t get SD card working, I decided to make a USB Host “fix” for my FEZ Panda.
Please take a look at my blog posts here: http://blog.tkjelectronics.dk/2011/03/fez-panda-and-usb-host/
And a video about my MP3 Player project here: http://www.youtube.com/watch?v=pcrbNAoaZME

Best Regards
Thomas Jespersen

@ mindThomas Good blog. Btw Gus made a post about Panda USB host awhile ago:

http://ghielectronics.blogspot.com/2011/03/usb-host-support-is-added-on-fez-panda.html

Your video is on GHI’s facebook and twitter :slight_smile: Nice work

Just curious… Was the problem with certain SD cards not working ever resolved? We are having the same problem, and my searches through the forums have so far led to dead ends.

I have a Patriot 4GB SDHC card in an SD expansion card connected to a Panda. For whatever reason, the constructor for PersistentStorage throws an exception:

#### Exception System.Exception - 0xffffffff (1) ####
#### Message: 
#### GHIElectronics.NETMF.IO.PersistentStorage::.ctor [IP: 0000] ####
#### Panda1SDTest.Program::Main [IP: 0008] ####

However, using the same SD card, I’m able to get through the constructor with no problems on a Panda Tinkerer board, and my Panda 2.

We’ve tried the capacitor across SD card power, with no luck. But if the same SD card works in the other boards (not using the SD Expansion Board)

The only solution we’ve found is to keep trying different SD cards until we find one that works, but it seems like there should be a better way.

Thanks,
Paul

Can we borrow the card you have? If so, we will happily look into it for you.

Yes, I can send it to you. I’ll try to get it sent out today.

Is this the correct address?

51410 Milano Dr. Suite 114
Macomb Township, MI 48042

Yes

Ok, it will be sent out FedEx today. Thanks for taking a look at it.

Can you try mounting few times?
For example:

sd = null;
for(trials = 0; trials < 2; trials++)
{
try
{
sd = new Pers…
}
catch{}
if(sd != null) break;
}

I could, but I mailed the SD that was failing to you guys yesterday. I’ll see if I can find another one that fails.

Got lucky and found a card I had forgotten about.

I put the constructor in a loop that ran 10 times. It threw an exception every time.

Anything else you want me to try?? Let me know.

We received the SD card. Everything seems fine on our hardware.

How do you have this “expansion” connected? Maybe there is something connected worng.

The SD expansion card is simply plugged into the row of connectors on the Panda (3V3/GND/MODE/IO44/IO45/IO46/IO47/IO48/IO49/IO50).

It’s your expansion board:
http://www.ghielectronics.com/catalog/product/181/

I’m assuming it’s connected correctly, because I can get other SD cards to work.

Just FYI, I tried running on a different Panda1 board with the same results (exception thrown in PersistentStorage constructor).

If you’d like, we can send you the whole setup. The Panda, SD Expansion card, and another SD card that doesn’t work (assuming we can get everything back when you are done with it).

Let me know if that would help at all.

There is a transistor on the SD exp that seems to be causing problems.
We connected the SD power directly to VCC without transistor and it worked fine…
We will send what we used back to you.

Is there a way we can modify our boards to verify things work here?

You will receive the modified board (free) which you can use to see where you need to do some soldering.

Great! I appreciate all your help. Thanks for taking the time to figure everything out.