SC20100 assembly mismatch

Hello All,
I have just started trying to implement some code with TinyCLR 2.
I have updated the firmware to preview 2 and am using the preview 2 nuget packages.
However I get the following error:

Found debugger!

Create TS.

Loading Deployment Assemblies.

Attaching deployed file.

Assembly: mscorlib (2.0.0.0) Attaching deployed file.

Assembly: GHIElectronics.TinyCLR.IO (2.0.0.0) Attaching deployed file.

Assembly: Tiny2Test (1.0.0.0) Attaching deployed file.

Assembly: GHIElectronics.TinyCLR.Devices.Uart (2.0.0.0) Attaching deployed file.

Assembly: GHIElectronics.TinyCLR.Native (2.0.0.0)

Error: the reference GHIElectronics.TinyCLR.Native cannot be used with this version of the firmware.

Firmware checksum 0xBBD3235C does not match the assembly checksum 0x0DF320E8.

Resolving.

Link failure: some assembly references cannot be resolved!!

Assembly: Tiny2Test (1.0.0.0) needs assembly ‘GHIElectronics.TinyCLR.Devices.Storage’ (2.0.0.0)

Assembly: Tiny2Test (1.0.0.0) needs assembly ‘GHIElectronics.TinyCLR.Devices.Gpio’ (2.0.0.0)

Assembly: Tiny2Test (1.0.0.0) needs assembly ‘GHIElectronics.TinyCLR.Devices.Uart’ (2.0.0.0)

Assembly: Tiny2Test (1.0.0.0) needs assembly ‘GHIElectronics.TinyCLR.Devices.Pwm’ (2.0.0.0)

Assembly: GHIElectronics.TinyCLR.Devices.Uart (2.0.0.0) needs assembly ‘GHIElectronics.TinyCLR.Native’ (2.0.0.0)

Error: a3000000

Waiting for debug commands…

The program ‘[5] TinyCLR application: Managed’ has exited with code 0 (0x0).

Any Ideas?
Thanks
Rob

Also I have tried with both

v2.0.0.21000-preview2

2.0.0.20000-preview2

Did you run the TinyCLR 2.0 Visual Studio Project System, VSIX file too?

http://new-docs.ghielectronics.com/software/tinyclr/downloads.html

Yes, it seemed to update it
image

1 Like

Also Firmware below as

1 Like

also some libraries

1 Like

Hello,
I cleared the firmware a few times a reloaded it.
that seemed to fix it.
cheers
Rob

1 Like