Main Site Documentation

RLP.LoadELF thrown System.InvalidOperationException


#1

Hello all,
I’m new in this community.
I’m working with Fez Panda 1 board and I try to use RLP, after its firmware update.
It starts, load elf image


byte[] elfImage = Resources.GetBytes(Resources.BinaryResources.RLPExample);

but when it try to load ELF in RAM it thrown an System.InvalidOperationException.


RLP.LoadELF(elfImage);

Someone know why? I have not found any information about this problem. :frowning:
Thank you in advance!
Andrea


#2

Please try the provided examples first


#3

I had already tried both examples, but the error occurs always! :frowning:


#4

Have you called RLP.Unlock?


#5

Remember that you need the unlock code GHI provides to you and RLP must be enabled.


#6

yes I received unlock code and it works correctly, RLP is enabled, like explained in “GHI Electronics NETMF Library”, but it doesn’t work.
The examples now work, but my elf file not. I have tried to re-compile it, but it is the same.
I don’t understand where the problem is.
Thank to all!


#7

I see in the system that you just got your RLP access so this is a good start.

Now, maybe your ELF is too big or at a wrong memory location…start with provided examples and make sure it works as is then gradually make changes to see where the problem is.


#8

Now it works!
I insert in Makefile “–omagic” option and the programs now works correctly!
Again
thank all!! ;D