Main Site Documentation

Resolve: unknown type: System.Diagnostics.DebuggerBrowsableState


#1

I’m really struggling with simple code which should just work but blows the device up.

The error I receive is…

Resolve: unknown type: System.Diagnostics.DebuggerBrowsableState
Error: ff000000
Waiting for debug commands...

The code which causes it is…



If I comment out that line then the board doesn't crash. Over the last few days I have found all kind of single line simple code which blows the board up.  Does anyone have any suggestions?

#2

Seems it was related to the deploy from VS2015. Grrr. Roll on the new firmware so I can use 2017. UsbHost…


#3

If you’re developing in netmf 4.3, or even using legacy 4.2 or 4.1, then the supported Visual Studio version is VS2013, not VS2015. Looks to me like you’re causing yourself pain by going off-target. I’d install VS2013.


#4

Yeah, I was just living on the edge so I could use all the compiler smarts of 2015. I knew it wasn’t recommended. I had tried it in 2013 although forgot to clean and recompile prior to deploying thus the error persisted making me think I wasn’t being bitten by 2015.

I’ve been using 2015 with Netduinos for years without problems but I’ll have to stick to 2013 without all the additional sugar.

Thanks!


#5

@ m1dst - Is this you?

***** Just looked at your profile, and it is you James.


#6

A very old photo you found on QRZ.com.


#7

Yes…
K2VPX


#8

@ m1dst - Some users have run into that issue before, the fix seems to be mentioned on https://www.ghielectronics.com/community/forum/topic?id=19818&page=1#msg195695