Main Site Documentation

Rename the OutputCompare to something more meaningfull!



I suppose that many people have the same problem as I had:
They want to output a digital signal and they start doing this in managed code which is quite slow.
Than they may think: “I should program this in RLP to get it faster.”

But they don’t notice that this functionality is already there.
Because the name is so strange and so misleading that it would never come into their mind that “OutputComapre” is just doing this!!

Could you please rename ‘OutputCompare’ into ‘SignalGenerator’ or something more intelligent ?

There is absolutely nothing compared when I output a digital signal.
A class ‘InputCompare’ could make some sense if it triggers when an analog input exceeds a certain level. But OutputCompare is just to confuse all FEZ beginners.





“Output compare” is actually what it’s called. GHI didn’t make up the term:


To PC developers OutputComapre doesn’t make sense but this is a very common name in microcontrollers.

Open a PICmicro or ARM micro datasheet for example.


Maybe OutputCompare is a known term for uP developers.
But I suppose that 98% of the .NET programmers who use a FEZ will not know it.
SignalGenerator would be more understandable for all.


I actually requested fro this change few months back so it could make it to next NETMF4.2