Raptor and TE35 Problem

I get the following error:

An unhandled exception of type ‘System.NullReferenceException’ occurred in Microsoft.SPOT.TinyCore.dll

Call Stack
Microsoft.SPOT.TinyCore.dll!Microsoft.SPOT.Application.OnEvent(Microsoft.SPOT.BaseEvent ev) Line 292 + 0xb1 bytes C#

Microsoft.SPOT.Hardware.dll!Microsoft.SPOT.EventSink.ProcessEvent(Microsoft.SPOT.EventSink.EventInfo eventInfo, Microsoft.SPOT.BaseEvent ev) Line 56 + 0x2c bytes	C#

Microsoft.SPOT.Hardware.dll!Microsoft.SPOT.EventSink.EventDispatchCallback(uint data1, uint data2, System.DateTime time) Line 67 + 0x15 bytes	C#

I Just started to use the Raptor board and I was getting this error, so I simplified the program to the very basics and still get the error. The program is:

using System;
using System.Collections;
using System.Threading;
using Microsoft.SPOT;
using Microsoft.SPOT.Presentation;
using Microsoft.SPOT.Presentation.Controls;
using Microsoft.SPOT.Presentation.Media;
using Microsoft.SPOT.Presentation.Shapes;
using Microsoft.SPOT.Touch;

using Gadgeteer.Networking;
using GT = Gadgeteer;
using GTM = Gadgeteer.Modules;
using Gadgeteer.Modules.GHIElectronics;

namespace Tidis_P10NMwtsr
    public partial class Program
        // This method is run when the mainboard is powered up or reset.   
        void ProgramStarted()
            // Use Debug.Print to show messages in Visual Studio's "Output" window during debugging.
            Debug.Print("Program Started");
            string td = "Test";
                GT.Color.Yellow, 2, GT.Color.Black, 1, 1, 100, 100);

The program runs but I get the error on loading. Removing the displayTE35 line and deleting the TE35 from Program.gadgeteer eliminates the error, therefore it it something in the TE35 end of things. I have the DP power source and the problem occurs both when powering with a 12V 6A power pack or just with the usb connection. I have changed all the cables. The DP module and TE35 display are all that is connected


This is not a productive weekend, first I have problems with the Hydra and DisplayN18 (see forum .Net Micro Framework for that problem) and now this issue. From the N18 problem, the TE35 is working with the Hydra board… I checked with FEZ config and the Raptor board is up to date with TinyBooter at and TinyCLR at

It might be related to touch. in the graphics designer, right click on the T socket cable and delete it. Or, define a touch related event handler.

Thank you, that solved the problem. Now to learn Glide!