Main Site Documentation

Question on 'O' command, Open File for Read, Write or Append


#1

I’m able to send the command to initialize the media using the IU0: command. The ALFAT responds to this command with response of \n!00.

After this I’m sending the ‘O’ command and the ALFAT responds with an error code of ‘10’. I’m using I2C to send the commands.
If it helps shed some light on anything, on sending the ‘V’ command immediately after receiving the error code of ‘10’, the ALFAT acknowledges the command with a proper response of ‘\n!00’ but does not send out the version string.

I evaluated ‘U’ and ‘O’ commands using UART and it works fine.

After sending every command, I do some dummy reads so I get the valid response code back and also NULL bytes back. Is that affecting in any way, the ‘O’ command.


#2

Uart and i2c are handled by the same command processor. They work the same. Try to send individual bus in i2c transactions at a slow rate and see if it works please.

And welcome to the community.


#3

Hi Gus,

I tried a slower clock for the I2C and it did not help. The I2C clock is running at 125 kHz and the datasheet says that it can run upto 400 kHz.

I solved the problem to open the file by waiting for a couple of seconds before I read the response. Once I do that I get “!00”.

This is the command string for O
O0A>U0:\AM\ZG.LOG

Now when I send the write command W0>5 [ 0x57 0x20 0x30 0x3E 0x35 0xCR ]

, it gives me <00><00>, all null value responses.

When I evaluate this command on the serial interface, the ACK is received quickly, in the order of few microseconds delay b/w send command ACK on RS232.

Waiting for suggestions.

Thanks.


#4

Adding to my above post, I’m able to write to the file but I’m still not seeing ACK from ALFAT.