Main Site Documentation

QUESTION: Anyone using Hydra with a PC with a processor speed of 3.0GHZ or more?


#1

I am interested in hearing from anyone on the forum who is using a PC with a processor speed of 3.0GHZ or more to do MF development with the Hydra.

I am tracking down an issue, and would be interested in hearing about the general experience of others.


#2

Mike,

What is the issue?

Setting up new i7-3960X 3.30GHz Win7 Ultimate


#3

USB on Hydra is not working for Mike and he thinks the problem shows on faster system. So far, Mike is the only one to report.


#4

Ok, I have noticed that the USB3.0 ports that worked while I was setting things in BIOS are not recognized by Windows.I had to plug keyboard and mouse into old usb ports. Looks like some extra Windows drivers have to be installed. I will try Hydra as soon as I am done with the rest of the setup.


#5

AMD Phenom II X4 965 processor @ 3.42 GHz and FEZ stuff on USB3 on a Gigabyte motherboard GA-870A-UD : no problem at all :snooty:

Of course, same (good) behaviour on USB2 ports.


#6

All of systems I have tried are USB 2.0.

Looking forward to hearing about your i7 experiences Valen.


#7

Mike,

I had installed everything including all the drivers from MB CD. So there are no warnings in the Device Manager. Everything is working great - no issues at all.


#8

Valen,

Interesting …

32 or 64 bit OS?


#9

64bit


#10

So Mike is the only one? :slight_smile:


#11

I run 6 cores overclocked at 4.2 ghz. (drool away, ladies )
64 bit Windows 7 12gb ram. Tons of stuff on USB, including two powered hubs.

Sadly, I haven’t done anything yet with the Hydra, but I’ve done a bunch with the spider.

What is it I need to try?

Pete


#12

Well, I have more ram than you. ;D

Lol.

As I understood Mike has an issue deploying on Hydra.


#13

Pete

Try to ping the Hydra from MFDeploy and deploy a project from VS.


#14

@ pete
Have you got some sort of DARPA project going on? That’s a lot of CPU power :smiley:


#15

Doesn’t everybody donate their free CPU cycles to DARPA research? (oops, I’ve shouldn’t have said that… they’re watching :o)


#16

My current project

www.darpa.mil/Our_Work/STO/Programs/Dynamic_Multi-Terabit_Core_Optical_Networks_(CORONET).aspx


#17

LOL, Hey Pete, so what is the rental time for that CRAY you have :wink:


#18

Heheh.

No, just tend to hate sitting around waiting for videos to encode. This machine cranks them out like nothing.

Scott Hanselman and I did simultaneous builds with the same key specs. We chose different video cards and memory, but same motherboard, case, SSD, etc. I water cooled mine, he air cooled his.

As it turns out, the motherboard is not great, so I wouldn’t recommend that to others.
http://10rem.net/articles/ultimate-pc-2010

I’m going to test the Hydra right now.

Pete


#19

This is the first time I’ve set up the Hydra. I plugged it in and it was detected as FEZHydra_Gadgeteer

I tried to deploy something from Visual Studio and it failed. Couldn’t find the defice

So then I tried to use MFDeploy to flash the latest firmware, as the firmware on the device was pre-pre-pre stuff.

Although the FEZHydra_Gadgeteer showed up under USB in MFDeploy, MFDeploy stayed locked for about 10-15 minutes when I tried to ping. It finally came back with “Error: No response from device” (man, that timeout needs to be shorter! Longest. Timeout. Ever. It reminds me of this Kids in the Hall recurring sketch in one episode where he stood outside someone’s house all day yelling for Lopez)

So then I went through the process of erasing it and then reflashing the bootstrap as explained on the Wiki. The log file seems to indicate it succeeded:


-I- Temp file : C:/Users/peter.brown/.sam-ba.testCompareFile
-I- Compare File : FEZ_HYDRA_TINYBOOTER.bin with memory at address : 0x8400 , for 59868 byte(s)
-I- Read File C:/Users/peter.brown/.sam-ba.testCompareFile at address 0x8400
GENERIC::ReceiveFile C:/Users/peter.brown/.sam-ba.testCompareFile : 0xE9DC bytes from address 0x8400
-I- 	Reading: 0x18C0 bytes at 0x8400 (buffer addr : 0x302CD8)
-I- 	Reading: 0x18C0 bytes at 0x9CC0 (buffer addr : 0x302CD8)
-I- 	Reading: 0x18C0 bytes at 0xB580 (buffer addr : 0x302CD8)
-I- 	Reading: 0x18C0 bytes at 0xCE40 (buffer addr : 0x302CD8)
-I- 	Reading: 0x18C0 bytes at 0xE700 (buffer addr : 0x302CD8)
-I- 	Reading: 0x18C0 bytes at 0xFFC0 (buffer addr : 0x302CD8)
-I- 	Reading: 0x18C0 bytes at 0x11880 (buffer addr : 0x302CD8)
-I- 	Reading: 0x18C0 bytes at 0x13140 (buffer addr : 0x302CD8)
-I- 	Reading: 0x18C0 bytes at 0x14A00 (buffer addr : 0x302CD8)
-I- 	Reading: 0xB1C bytes at 0x162C0 (buffer addr : 0x302CD8)
Sent file & Memory area content (address: 0x8400, size: 59868 bytes) match exactly !
GENERIC::SendFile GHI_OSH_BOOTSTRAP.bin at address 0x0
-I- File size : 0x25E8 byte(s)
-I- 	Writing: 0x18C0 bytes at 0x0 (buffer addr : 0x302CD8)
-I- 	0x18C0 bytes written by applet
-I- 	Writing: 0xD28 bytes at 0x18C0 (buffer addr : 0x302CD8)
-I- 	0xD28 bytes written by applet
-I---------------------------------
-I-        Script Completed       -
-I-     Please Reset the Device   -
-I---------------------------------

After erasing the Hydra (using the socket 3 jumper approach), it showed up as COM11 as a camera device. After flashing the bootstrap, the Hydra wasn’t redetected as anything else.

I hooked up a button to socket 14 and pressed it while holding reset.

Pinging via MFDeploy still fails, so I haven’t been able to deply the netmf firmware

Is this what you’re seeing, or did I botch some other step?

(intel Core i7 980x stock is 3.33ghz, running at 4.2ish, Win7 x64)

Pete


#20

Actually, as it turns out, MFDeploy only gives up if you disconnect USB. Infinite timeout otherwise.