PulseDebugLED() on Cerberus

I’m not sure if this is related to the new beta release or even what the old status of this was since I can’t remember the last time I used PulseDebugLED(). However, I just tried using it with a Cerberus and it didn’t pulse. It just turned the LED off and execution ended. I tried starting it directly in ProgramStarted(), in a separate thread, and in an endless loop within a separate thread. None worked as expected.

Hi, welcome to the forum.

For us to effectively help you, it’s likely we’ll need to see your code. You can add that here, but don’t forget to use the code tags to make sure it gets formatted appropriately.

( :smiley: )

1 Like

You’re killin’ me @ Smalls!

On the serious side:

        GT.Timer timer = new GT.Timer(1000); 
        void ProgramStarted()
            Debug.Print("Program Started");
            timer.Tick += timer_Tick;
        void timer_Tick(GT.Timer timer)

worked fine for me

Works for me too. Not sure why I didn’t try this version the other day. I was thinking that PulseDebugLED() had a wait built into it and so I was putting it in a tight while loop in its own thread. Thanks for the reminder.