Project - Using an Azure Mobile Service with Gadgeteer

I just posted Using an Azure Mobile Service with Gadgeteer on Codeshare. Feel free to discuss and make suggestions here.

13 Likes

I never thought the video would take so long to render… my F5 key is a little worse for wear! Great project !!

Cool. Will investigate closely soon. How easy is pictures/blobs with these libs?

@ njbuch you are in luck as here is a sample project where someone is using pictures/blobs with Azure and Gadgeteer

http://www.awsomedevsigner.com/2014/01/25/first-steps-with-net-gadgeteer-and-windows-azure/

Hopefully Ilija is a forum member here as this is cool.

Very Cool.

Thanks for sharing.

Have you had any issues with Azure in general? I was developing an app using Azure storage, but Azure went wacky. I was charged for transactions I didn’t create (ok, maybe I was hacked), storage I wasn’t using (again, maybe hacked), and worst of all, none of the data was visible anywhere. All seven blobs were empty, no way to access the 1.5 TB of data I was supposedly storing (maybe AZURE was hacked?). I got most of my charges back, but that doesn’t compensate for the hours of development on a project I had to scrap since MS can’t give a rational explanation for, or even reasonable acknowledgement of, the issue. It went much deeper, but I’ve ranted enough. Just curious if this is a common experience or just a fluke.

I’ve never had a problem yet with Azure, but of course everyone’s mileage differs with everything, but everyone I know working with Azure with hasn’t had any problem either. We have an Azure code camp coming up in Calgary so I’ll enquire there about problems as well

Is it any more difficult using a WiFi module?

Shouldn’t be. Right now I’m working on a Gadgeteer MQTT demo where I’m using a WiFi module on both the device and controller.

Which MQTT client library are you using? Based on this listing (http://mqtt.org/wiki/doku.php/libraries ) it looks like there are three to choose from.

M2Mqtt https://m2mqtt.codeplex.com/ as its one of @ ppatierno libraries and he writes rather good stuff.

3 Likes

Hello,

Thank you for the very detailed walk-through and sample code that I thought I followed exactly. But when I execute the myTable.Insert I’m not getting back any errors and the result is what I want to be inserting:

“{ “headline” : “Harrison soaking in first All-Star experience”}”

I intentionally gave the wrong table name and messed up my key so I’m guessing it’s not correctly connecting to my mobile service. Any tips?

Thanks in advance -

Figured it out - it didn’t like https for my mobile service. Took the s out and it worked fine over port 80

1 Like

@ hvelo - not sure if you got anywhere with your wifi project, but please take a look here - https://www.ghielectronics.com/community/forum/topic?id=16288

I welcome your feedback.

J.

1 Like

Did anyone manage to simply make a graph/display the data in a simple way?

Are there more current library’s out there for uCloudy?

Is there a way to not have to build the class in my project and just create the row based on Azure table definition?

I’ve tried to follow along in your video and have a few questions…

In the video, your initial project has both the UCloudyNetMF42 and 43. You then say build and then reference in Gageteer project. I was expecting only one and perhaps the UPLibrary43?

I’m getting errors like when I build the uCloudyNetMf43. Did I extract/download incorrectly?

Error 1 Source file ‘…\uplibrary\uPLibrary\Networking\Http\HeadersCollection.cs’ could not be found C:\Users\Ed\documents\ucloudy\ucloudy\uCloudy\CSC uCloudyNetMf43

@ Fast_EddieD - To compile uCloudy project you need the upLibrary project as the HTTP stuff is in that library ( uplibrary\uPLibrary\Networking\Http ). I believe my demo project contained both projects and used version 4.3, the 4.2 stuff was in there as the downloads contained 4.2 file as well as 4.3.

uCloudy Mar 26, 2014 https://ucloudy.codeplex.com/
upLibrary Mar 26, 2014 https://uplibrary.codeplex.com/

As for creating the tables from Azure row definitions, it might be doable, but certainly not easily.

@ Duke Nukem - Very good video and explanations on how to use AMS - especially for beginners. Azure is as complex (in terms of the amount of features) as it is easy to use. The problem is to choose the right service for the job. The nice thing is that you can combine the NetMF devices with a mobile notification interface very easily using mobile services. Paolo is doing a great job as well with his work on uCloudy and different other libraries as well. Always great code quality and usability.

@ Fast_EddieD - I recall a similar experience when first using these downloads for uCloudy. It’s been a while since I used it but I seem to remember that the issue was the links were broken in uCloudy for the upLibrary references it used. I remember having to remove the references and add then again using the actual files that existed. The icons in VS for the HttpBase.cs, HttpClient.cs, etc had a warning triangle on them I think.

Sorry to be vague but maybe that’ll help a little.

@ Duke Nukem - I’m still confused. Let me explain what I am doing…

I downloaded both libraries and saved in a Download folder. They are in different folders but at the same level.

I opened the uCloudy project in VS2013. It created a solution called uCloudy with two projects uCloudyNetMf42 and uCloudyNetMf43.

I then added another project to the solution from uPLibraryNetMF43.

uPLibraryNetMf43 is compiled/built without errors

Please look at attached snapshot.

I am trying to compile the uCloudyNetMF43 and getting those errors. I tried adding a reference to uPLibrary from NetMF project to no avail.

You glance over this in your video at about the 9 minute mark. I must be missing something really basic.