Main Site Documentation

Project - Game-O Emulator


#1

I just posted Game-O Emulator on Codeshare. Feel free to discuss and make suggestions here.


#2

I’m new to all this but very excited to get me GameO!

I have tried to get the emulator to work but, I’m having a little trouble. I have downloaded it and it compiles without error but, when I run it I get the following (see image).

I’m not quite sure what I am doing wrong?


#3

The Game-O emulators (I now recommend the community edition http://www.ghielectronics.com/community/codeshare/entry/776) do[em] not [/em]create an Application that can be run all by itself, it must be loaded with a program from another project. There is preliminary documentation at: http://www.ghielectronics.com/docs/222/the-game-o-emulator and http://www.ghielectronics.com/docs/207/fez-game-o


#4

OK but, I’m still confused on how I get it to show in the list of emulators in my project? The documentation say to runt it(deploy) – not sure what that means…


#5
  1. Please site the exact reference for [quote]The documentation say to runt it(deploy)[/quote] so I can make sure to clarify the documentation… Thanks!

  2. the document http://www.ghielectronics.com/docs/21/first-netmf-project starts out with a simple “deployment” to an emulator. When deploying to the Game-O emulator you will follow the same directions but in the “Device” drop-down list you will choose the gameo emulator.


#6

For the Emulator to appear in the list of the emulators you will need to build the Emulator project itself. That project has a special task that when executed “installs” the emulator so the Visual Studio will see it.


#7

Sorry – here is the line in the documentation about the deploy statement – You must build the project and run it (deploy) for the emulator to install on your system.

It is in the Game-O emulator documentation: https://www.ghielectronics.com/docs/222/the-game-o-emulator

Here are my steps:

  1. I have downloaded the project (776_904_GameOEmulator.zip) unzipped and opened the solution in VS 2012.
  2. Click the Build menu option to build the solution, I can build the project with no errors. At this point am I supposed to run the project?
  3. I click the Start button and when I start the project I get the emulator to come up fine, it just shows the error window I posted previously, also it does not show in the list of emulators in VS.

Sorry guys I must be missing some simple step. Any other suggestions?


#8

Good, so Emulator builds fine. Next step.

Can you start new visual studio and create new NETMF project.
Make sure to switch target framework to 4.2 (important, it will not show up for 4.3 netmf projects). Check deployment tab you should see the emulator in the drop down.


#9

OK that was the piece that I was missing. I had my project targeted for the 4.3 framework, after switching to the 4.2 everything works fine!

I now see this step under the first example in the Game-O documentation - maybe should have went to that first before I posted.

Thanks for all the help!


#10

You are welcome!


#11

@ Silverball - The instructions probably weren’t there the first time you looked, they are evolving rapidly based on community comments and internal schedules. I just added comments about 4.2 vs 4.3 based on Architects comment.