Problems with Vs2010 Ultimate and Project Templates

Hi everyone,
today i’ve received my Fez Spider Kit.
I’ve followed the instructions on the support page and installed all the required packages but when i try to create a new “.Net Gadgeteer Application” vs hangs.
The project file is missing the program.generated.cs and all the references to GHI modules assemblies.
Every time I try to open the graphic designer vs hangs.

I’ve manually added the program.generated.cs and the references to the required (by my board configuration) modules all works fine; i’m able to build, deploy and debug my project.

Vs still hang (takes 100% of one core and over 1gb of ram).

Same issue on my workstation (win 7 x64) and my macbookpro (parallels + win7 x64).
Visual studio 2010 Ultimate
Tried both MF 4.1 && 4.2 RC.

Any suggestion?


Hi Andreabalducci and welcome to the forum.
The first question is have you updated the firmware on your spider. This is pretty much the most popular problem with a new system. Also make sure that you installed everything correctly including the .netmf 4.2 .
When you create a new gadgeteer project it should automatically give you the gadgeteer designer and create the program.generated.cs file. You should not need to ever edit that file.

When you plugged in your spider what does it say in device manager?

Welcome to the forum! I would suggest trying Visual Studio 2010 Express to see if the issue still occurs?

@ HughB - it’s not a board issue, the board just works with mf 4.1 && mf 4.2. It’s a vs designer issue; if i manually write the code without using the designer all works fine.

@ James - cannot install vsexpress side by side with vs ultimate.

Ahh I see.

i would make sure i have the latest Service packs installed for VS2010 at least SP1 and any available updates.

Welcome to the community!

Did you install all the packages and let them finish? I think one of them (I forget which) looked like it kept restarting unless you look closely to see it is a slightly different package name because it was really a manager for a bunch of installs.

I’ve setup a win8 vm with vs express 2010 and all works fine. I think there’s something wrong with the Ultimate edition and the visual board editor.

@ andreabalducci - i run ultimate on both win7 and 8 without issue.

@ Justin - tried on two different pc and i’ve the same issue :frowning:

@ andreabalducci - very odd, out of curiosity what os and vs language?

@ Justin - win7x64 eng

@ andreabalducci - vs en as well?

@ Justin - yes, en from MSDN subscription.
Reinstalling all (express && ultimate)

@ andreabalducci - good luck, we are ultimate msdn and all happy here.

reinstalled and still not working. have modified the project template to avoid the automatic opening of the designer, so i can create new projects without crashing vs.

Did you try removing and reinstalling all of the Gadgeteer stuff?

@ PintSize.Me - yes, more than once. Same bins works fine with vs express in a win8 vm.
On my 2 dev box with win7 nothing to do.

@ andreabalducci - this is a very strange issue indeed. Even though you have the Ultimate edition through MSDN in English, what is the locality setting on your computer (as there is a known issue with international locality settings, however not exactly as you describe this). Could you ensure that your locality is set to English and the US? Windows help & learning is how to change this, if you have never checked/changed this before.