Main Site Documentation

Problems with USB to Serial "No Response from Device"


#1

Not sure what I’m doing wrong here. Bought the “Ultimate” kit. I can run programs just fine on the standard USB -> USBizi. When I hook up the USB to serial (according to the documentation) and plug in the USB to serial I get the “sound” but MFDeploy can’t see the port. When i unplug the device, I lose COM4, so I’m pretty sure COM4 is my device.

I’ve tried:
Updating the FTDI drivers
Made sure the Mode and GND pins are jumpered

When I click ping, I get a red flashing light on the TX on the USB to serial. But I can’t get it to ping from MFDeploy, and therefore can’t see it in .NET.

Help?

Thanks,
Mark


#2

You have to add a wire to short MODE pin to ground. Which is also available as a jumper on FEZ Touch display board.

Welcome to the community.


#3

Thanks very much for the quick response. I have those pins shorted (have done it from both the main Panda II board and from the jumper on the under-side of the touch display) - still doesn’t work. I know it’s getting connected because when I plug in the cable to the USB to Serial connector e-block, I get a sound in Windows. When i plug in the other one (directly to the Panda) - no sound.

Help?

Thanks,
Mark


#4

you did connected the RX on the usb-to-serial to TX on the connect shield and TX on the usb-to-serial to RX on the connect shield, right?

Did you unplug/plug in power after setting the mode pin to ground?


#5

Yes to both. Incidentally, when I connect RX to RX and TX to TX I get a ton of flashing lights on the device. But I know that’s not right and have switched it back. And yes - I’ve reset the power/device multiple times. I’ve even wiped the device to make sure a program wasn’t interfering…


#6

The flashing lights could be due to boot up messages being sent.


#7

Can I suggest you get standard serial input and output working on the device before using the mode jumper, so you know that the connection to your PC works? Also you should check out device manager and see what devices/ports come available when you connect the devices?


#8

try this again and don’t mind the flashing leds


#9

Eric and Gus:
Okay, so - no go on the “rx to rx and tx to tx”. While I get the multitude of flashing lights, it still doesn’t connect no matter what I do.

Brett:
I know that it’s COM4 as both MFDeploy updates when I add/remove it and that’s what Device Manager reports. I haven’t done it with the “mode” connected set to default (not hooked up). Do you have some sample code that I can use that should work when I use the Serial dev as a standard serial device?

Thanks,
Mark