Problems with Motor Driver L298 Module

Hello, I’m new
I recently bought a Fez Hydra and Motor Driver L298 Module. Today I faced a problem. I connected the module to the battery and the motor (photo in attachment) and wrote a simple program:

public partial class Program
        bool motorStarted = false;

        void ProgramStarted()
            button.ButtonPressed += OnButtonPressed;

        void OnButtonPressed(Button sender, Button.ButtonState state)
            motorStarted = !motorStarted;

            if (motorStarted)
                motorControllerL298.MoveMotor(MotorControllerL298.Motor.Motor1, 100);
                motorControllerL298.MoveMotor(MotorControllerL298.Motor.Motor1, 0);

but the motor is not running. If the motor is connected directly to the battery to all works. Who can say what might be the problem?

@ beamyplum - Welcome to the community.

Have you tried using MotorControllerL298.Motor.Motor2? I have this module and have had it connected exactly like you have and it worked. I am not able to check the code now so I cannot confirm which Motor constant I used, maybe it is worth trying if you have not already tried.

Check that your button pressed is firing properly too.

I tried to connect both motors - the result is the same

Button pressed event is firing, when button is pressed - led’s turn on.

Faulty module, perhaps. Measure the voltage on motor pins with voltmeter.

Do the LEDs on the module come on? Also have you tried a value less than 100, the driver actually has some explicit code to handle the case when 100 is passed so maybe you could try something like 80 to see if there is any difference.

First photo: voltmeter connected parallel with motor
Seconf photo: voltmeter connected to chain without motor

This is a 9V battery right?

Have you try to use a different socket on the main board?

Yes this is a 9V battery

i can’t connect Motor Driver L298 Module to another socket: Visual Studio designer allows to connect this module only to the socket #7

Hmm, maybe 6.9V is not enough for that motor. Running out of suggestions.

This motor require 2.4V.
I think problem in battery. I tried to use my notebook power supply unit to power Motor Driver module (15V) and this is works