Problems with G400 and SD over SPI

on G400? If we did not confirm the report or not showing here
https://www.ghielectronics.com/docs/227/post-release-issues then we missed it. Please report it again or call/email us with the issue so we can look into it. We must have missed it?

We are very actively working on G400.

@ Gus

OP provided small application that shows the problem in message #4 on page 1 of this thread:

https://www.ghielectronics.com/community/forum/topic?id=13444&page=1#msg137269

I will forward to the team, thanks

Thanks for the support Gus. This is one of the reasons I have stuck with GHI now and have a number of your products in development and for hobby use.

I am hoping the G400 will come good in very short time and I am pleased to hear that it will be in production for a long time.

@ Gus - Yes, thanks Gus!

I also really hope G400 can work as replacement for the ChipworkX module really soon, because we are in the exact same situation as you Dave (having custom hardware products based on ChipworkX with potential orders coming in quite soon).

Since this is my first topic in here, I of course also have a stupid question - do I accept Gus’ answer of reporting it to the team as a solution? Or should I “leave it open” until the issue is actually resolved?

It is up to you.

@ MD There is a bug with SD cards over a certain size. Could you try to test with cards below 2GB and see if it works?

I hope this can be fixed. Getting hold of 2GB cards around here is near on impossible now and the stock I had from a few months ago is empty. The smallest I can find now is 4GB. There are 2GB cards sold here but I have had so many issues with that make, I only purchase Sandisk now for commercial use.

I’m just about to list a few 1Gb ones on ebay, but they’ll be expensive, do you want me to post the link once I’ve done it ? :slight_smile: :slight_smile: :slight_smile: :slight_smile:

(no I’m not, but I thought I should say that).

And I suspect now the bug has been identified it’s on the radar to be addressed - John will let us know if we need to lobby Gus, or to up-vote something on codeplex right :wink:

@ John - I just tried with a 1GB Micro SD with adapter and unfortunately with the same result as before: IOException - CLR_E_INVALID_DRIVER.
So unless it doesn’t support Micro SD cards, the bug with larger SD cards, seems to unfortunately not be the problem here.

Which cards are you guys at GHI testing with to get this to work (manufacturer, size and type)?

The size limitation is fixed in a coming firmware.

We are able to reproduce the problem and will let you know when we have more.

In the current firmware, you must use SD as root for device in paths, SD_SPI is only used in constructing the PersistentStorage object. In the coming SDK that is corrected so that SD_SPI is the root used in paths. As for the size limitation, any sized media will work, but those with a size over 4GB will be capped at 4GB in reported size. Operations such as reading, writing, and formatting work properly and can use the entire size.

1 Like

@ John - That’s very good news, thanks John! I have tested your solution with my 1GB micro sd card now, and using SD instead of SD_SPI after the mount, works perfectly.

@ MD -

Should use


 string rootDirectory =
                    VolumeInfo.GetVolumes()[xxx].RootDirectory;

then it doesn’t matter SD MCI or SD SPI, so you don’t need to change your code a lot in the future.