Main Site Documentation

Problems flashing G400 to 4.2.11.2 on Win 8.1 U1


#1

I started working again with my Fez Rapter yesterday and was trying to update to the new versions, but I am having some difficulty.

For starters, I made the mistake of updating the firmware first, which caused VS.NET to not be able to deploy anymore. This is when I discovered I forgot to do the boot loader first (see attached “loader-firware.png”). How much of a problem does this pose?

When I finally figured out how to get the device in the bootloader mode vesus debug mode, my attempts to flash failed with a script error (see attached “script-error.png”).

Along the way, I found a couple of odd things that go against the guide:

  1. The unspecified device it detects is called “GPS Camera Detect (COM4).” Notice that the name seems way off, but also that the COM is not padded to two numbers (i.e. COMXX). See the attached “unspecified-device.png” for a screen shot of this.
  2. The flashing “commandprompt.bat” had to be run from a console that was “Run as Admin” or it would get permission errors.
  3. Had to run ProgramG400.bat like “ProgramG400.bat COM4” for it to detect that a device exists, but I then get that script error
  4. The Atmen page has a SAM-BA 2.12 update 6, that I tried first then uninstall everything and tried without it. The same script error occurs in both cases…

Any ideas on how to correct or fix this?

Thanks!


#2

Since you get the wrong name for the device, I assume windows chooses the wrong driver.
May be you have another driver installed on your machine, which was designed for a device with the same USB chip.
You could Open the Device manager, look for the device there, right click and install a different driver. Then you choose to manually select the driver.
Unfortunately I can not give you exact instructions, because I don’t know it out of mind, but normally it’s not too hart to find out how to do it.


#3

@ Reinhard Ostermeier - Well I certainly don’t have a GPS device plugged in.

One thing that did happen when I first got into bootloader flashing mode, is windows installed the driver on its own. Maybe I just need to manually change the driver loaded one Windows detects it? If so, do you know where I can find the driver on disk?

Thanks!


#4

@ Reinhard Ostermeier - Found it. I’m thinking it doesn’t support Windows 8…I tried forcing it but windows thinks its not a match…


#5

@ andre.m - I believe the correct path is C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\G400\Firmware\TinyBooter\drv\

sam-ba_2.12 is installed


#6

@ Reinhard Ostermeier - I tried to force it and I get the following


#7

I found a way to prevent this check in Windows 8. Requires a reboot though, so I will be back shortly…


#8

That worked! But now its stuck in loader mode even though device manager shows the debug driver loaded…

Rebooting like it suggests has no effect


#9

@ jvetter - Nevermind, the reboot re-enabled it. Thanks!