Main Site Documentation

Problems encoutered migrate FEZSpider Demo board from 4.1 to .NETMF v4.2


#1

I started migrating my FEZ spider board which I bought a year ago with 4.1 firmware to .NETMF4.2.

I successfully upgraded the frimware, using “C:\Program Files (x86)\GHI Electronics\GHI FEZConfig”

However, now I need to migrate my existing apps.
I ran into problems with references assemblies.

First, in my 4.1 app, a path to the .NETMF 4.1 SDK existed, that prevents my GHIElectronics.Gadgeteer.FEZSpider.dll from updating to C:\Program Files (x86)\GHI Electronics\GHI .NET Gadgeteer SDK\Mainboards\FEZSpider\NETMF 4.2\GHIElectronics.Gadgeteer.FEZSpider.dll

When i removed that project path, that problem was tackled.

Now I deployed my app, debugging it.
That gives me errors on a set of “old” GHIElectronics assemblies:
GHIElectronics.NETMF.Hardware.dll (4.1)
GHIElectronics.NETMF.IO.dll (4.1)
GHIElectronics.NETMF.System (4.1)
GHIElectronics.NETMF.USBHost (4.1)

They are “old” refs to the GHI 4.1 SDK.
So, I guess I probably need v4.2.x of those assemblies.

However, I tried all updates (2013 R1, R2, R3) of the SDK, but I dont get any new GHI .NET gadgeteer 4.2 SDK, under C:\Program Files (x86)\GHI Electronics

What do I need to do to resolve this?


#2

Welcome to the forum.

1st thing to do is changing the target framework in the project properties from 4.1 to 4.2.

Then you need to remove every single GHI reference from the project and add it again.
Unfortunately this is necessary on ever SDK update.

After this you might run into some compiler errors, because some namespaces, names and features have changed between 4.1 and 4.2


#3

I think I cracked it.

  1. Remove old GHI SDK (control panel/instelled apps)
  2. Install latest SDK R3 package from GHI
  3. Run FezConfig
    -Detected 4.2.4 on board, 4.2.11 on laptop
  4. Installed new TinyBooter
  5. Upgraded Firmware to 4.2.11 (Mind the dipswithes!!! 1,2,3 -> on)

I think the R3 4.2 is now called “Premium”?
C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK

-Remove refs in app to
GHIElectronics.NETMF.Hardware.dll (4.1)
GHIElectronics.NETMF.IO.dll (4.1)
GHIElectronics.NETMF.System (4.1)
GHIElectronics.NETMF.USBHost (4.1)
-Created refs to
GHI.Premium.Hardware.dll (4.2.11.1)
GHI.Premium.IO.dll (4.2.11.1)
GHI.Premium.System (4.2.11.1)
GHI.Premium.USBHost (4.2.11.1)

-Clean/rebuild app

-Debug

-Go!

That seems to work, at least LCD and button working again.
Now the rest of my hardware schisle.


#4

Yep, looks like you figured it out. :clap:

The SDK contains OSHW lib and Premium lib.
Premium lib can only be used with GHI premium boards (like your Spider).