Main Site Documentation

Problems debugging ChipworkX with VS2010


#1

Not really specific for this forum perhaps,
but still I’m hoping there are others who’ve had this

Been working on something for some time, without any problems,
now lately whenever I start or stop a debug session with the ChipworkX it takes ages for VS2010 to respond (usually ends up in a white overlay … not responding)…

Any suggestions?
It’s really annoying to debug something like this.


#2

Do you have any extensions to VS installed? I would disable any extensions/add-ons. The only other thing I can think of is if you have a tight loop like:

while(1)
{
    //do nothing
}

Stuff like that can make it hard for the debugger to attach as the processor is completely tied up.


#3

Well I definatly do not have a loop and the blocking is before the app is even run.

As for addons, the only one I have is devexpress,
although I did not have any probs with it in the past,
I’ll try to disable it.


#4

Disabling all add-ons (resharper being the only one)
did not help at all.

As for the loop.
After the application finally starts,
let’s say I put a breakpoint on:

if (!Directory.Exists(path))

And then terminate execution it takes up to 5 minutes for VS2010
to respond again. Even disconnecting the hardware does not help.


#5

The only other test I can think of is to load a very simple program on the board and see if the symptoms remain.


#6

As I expected, a new project boots and stops in no time
Now, even if I remove all the code from the Main in the other project, the problem persists.

Come to think about it, it’s not the first time it happened.
Last time I had to create a new solution, create new projects in the solution and copy all files from the old solution.

It’s clearly something in VS2010 that gets f* up…

But it’s hard to imagine I’m the only one with this problem.


#7

Are you using new beta firmware?


#8

Nope,
I’ve been working on this project for a while,
have not updated any components on the development system either.

As this is not a project I can ‘fool around’ with :stuck_out_tongue:
It just started… (just like it did in the past) It’s like something gets poluted.

Cleaning the build, removing the .user files, removing the bin / obj folders, nothing helps…


#9

I should also note,
when switching the project from USB/ChipworkX to the Emulator,
vs2010 has no problem starting/stopping the application.

As soon as you use the ChipworkX again it’s game over.


#10

Ignore that last message.
While starting the app is faster, stopping the app while running in the emulator still causes vs2010 to freeze


#11

Eventually I created a new solution for every project,
this way when VS decides to f*** things up again the damage will be limited
(as this has happened before, and will probably happen again)

Now the same code, starts/stops in no time


#12

Can you run a diff on the .sln for the working and non-working to see what has changed?


#13

Just had the same for a Panda project… just stopped working,
didn’t even close VS2010 between the time it worked and the time it stopped.

And we’ve tried many panda II devices…

Output Windows:


Resolving.

Link failure: some assembly references cannot be resolved!!


Assembly: Microsoft.SPOT.Hardware.SerialPort (4.1.2821.0) needs assembly 'Microsoft.SPOT.Hardware' (4.1.2821.0)

Assembly: System.IO (4.1.2821.0) needs assembly 'Microsoft.SPOT.IO' (4.1.2821.0)

Assembly: Signax.LibDigits (1.0.0.0) needs assembly 'Microsoft.SPOT.Hardware' (4.1.2821.0)

Assembly: FEZPanda_II_GHIElectronics.NETMF.FEZ (4.1.6.0) needs assembly 'Microsoft.SPOT.Native' (4.1.2821.0)

Assembly: FEZPanda_II_GHIElectronics.NETMF.FEZ (4.1.6.0) needs assembly 'Microsoft.SPOT.Hardware' (4.1.2821.0)

Assembly: FEZ Panda II Application (1.0.0.0) needs assembly 'Signax.LibDigits' (1.0.0.0)

Assembly: FEZ Panda II Application (1.0.0.0) needs assembly 'Microsoft.SPOT.Hardware.SerialPort' (4.1.2821.0)

Assembly: FEZ Panda II Application (1.0.0.0) needs assembly 'Microsoft.SPOT.Hardware' (4.1.2821.0)

Assembly: FEZ Panda II Application (1.0.0.0) needs assembly 'Microsoft.SPOT.Native' (4.1.2821.0)

Assembly: FEZ Panda II Application (1.0.0.0) needs assembly 'System.IO' (4.1.2821.0)

Error: a3000000

Waiting for debug commands...

The program '[0x1] Micro Framework application: Managed' has exited with code 0 (0x0).



#14

And here’s a nice kicker…

I reverted the entire solution to a revision from a day before,
and still the deployment is broken… clearly I’m going WTF right now


#15

Did you try cleaning out your bin & obj directories? This could end up being one of those case where only recreating the solution fixes it…


#16

@ ianlee74 You’re a life saver :slight_smile:

The bin and obj directories are ignored by mercurial so they weren’t reverted.
The “Clean Solution” option in VS2010 doesn’t do a good job

Before I did indeed fix solution by recreating them,
but we have projects that contain like a hundred source files and lots of directories

You saved me quite some time, thnx!


#17

Glad I could help. :wink: