Main Site Documentation

Problem with Wifi module


#1

Hi all!

I have a very strange problem with Wifi_RS21 module. I’m using the FEZ Spider Mainboard and .NET Micro Framework 4.1. Unfortunately, I can’t update it.

The problem is that, when I call the Join method, the board immediately resets. I have tried connecting the module to Socket 6 or 9, and no other module (exept, of course, the UsbClient), but the result is the same. I have tried connecting the board directly to the PC or via a powered USB hub, but with no success.

The strange thing is that the problem has appreared in the last days. In the past, everything worked correctly.

What could be the reason of the problem? Maybe is my module damaged?


#2

I can’t update because I’m using other 3rd party modules that use drivers (with no source code) that aren’t compatible with .NET Micro Framework 4.2.

It is my FEZ Spider that resets.


#3

I have already tried, I obtain some messages like

Stepping into non-used code: RS21.Join

(the method name probably isn’t correct, I don’t have the module right here) and then the board resets. No other messages appear.


#4

Often, also the Scan method causes the reset of the board, while sometimes it works and returns the correct results.


#5

Power?


#6

Excuse me, what do you mean?

I have tried connecting directly to the USB port of the PC, when no other device was connected, and also with a powered USB hub.


#7

Try to add a power pack


#8

Tried also this, with a battery Pack with 9 volt and one with 18 volt, but the result is always the same.