Problem with FEZ Panda 2 Network shield

Hello,

I currently have a Problem with the FEZ Connect Shield. I’m using it with a FEZ Panda 2. I use both devices to control the room lights.

I use relays (12V) to switch the lights on and off. The relays are powered using a relay driver (ULN…).
Everything works fine until I switch on an old neon tube. The FEZ Panda still works but the FEZ Connect shield stops working. I cannot connect to the WebServer anymore. If I reset the FEZ Panda 2 (toggle power on and off), everything works again.

Does anyone have an idea how to solve this problem?

Maybe useful:

  • I use the 5V pin to supply power from an external 5V supply.
  • I use a MAX7311 to control the relay drivers (10 relays).
  • It only stops working if the neon tube is toggled. All other lights are working fine.

@ ChrisK - I’d start with basic troubleshooting steps:

  • did this ever work with the neon tube?
  • if so, did anything change before it stopped working?
  • have you tried switching out the neon tube for a normal light to see if the issue is the relay?
  • have you tried putting the neon tube on a separate relay?
  • have you tested the neon tube separate from the Panda II and relays, and does it work standalone?

I have not tried combining microcontrollers and neon, but as I recall from working with neon for a stage play I did many years back, they operate at very high voltages from the transformer. Perhaps that causes interference.

I’m not an EE, but I have to wonder if perhaps you might need an optoisolator to prevent issues between the neon transformer and the rest of the circuit.

Just some thoughts…hopefully at least a little helpful. :slight_smile:

Is the neon tube sharing the 5V supply? Turning something on , and getting funny results, is often a problem with insufficient peak current from a power supply?

I would look at some shielding as the neon’s can kickout some quite high RFI which maybe causing your problem.

@ Sprigo - Theres a shield for that!(no there isn’t)

Thank you for your replies.

I have 10 relays with different kinds of lamps. One of these relays controls the power of an old “wurlitzer music box”. All these devices are not affecting the network shield.

The neon tube is not sharing the 5V supply. It has its own (very old) transformator. This transformator (230V) is controlled by the relay.

If I disconnect the neon tube from the relay, everything works fine.

I’m confused because the Panda 2 seems to be “protected” and works even with the connected neon tube. Only the network shield stops working (Socket.Accept waits forever).

When I see this kind of behaviour, I usually don’t look at the hard things first. If it only happens on the one output, the thing that’s being turned on is to blame. It’s almost certainly interference from “the unit” that is causing the behaviour change.

While on behaviour changes, do you know for sure the rest of your system is still executing ? Do you have for example push buttons that can also turn off the relays, and do they still operate ?

Did you swap relay outputs to prove it’s not something in your code to turn the neon tube on ?

Did you try pinging the device while the neon tube isn’t on and then when you command it to go on?

I’d still be pretty comfortable that it’s interference. Either the neon tube or the transformer is causing sufficient EMI to affect the network.

The whole solution has buttons for each relay. I use a PCA9555 with 11 buttons. These buttons are used to toggle a single relay or to apply a special schema.

Another way is to use a web app at the smartphone which has the same features.

The part with the hardware buttons works without any problems. Even with the connected neon tube. I also have a button with toggles everything on and off. All of these buttons are working for a couple of weeks now.

But the Socket directly stops accepting connections if the neon tube goes on. It directly stops after the first time. The buttons are still working.

I also tested without the neon tube (and transformator). The socket is working without any problems. I have tried everything to kill the Socket (toggling every relay multiple times as fast as possible, toggling all relays at the same time) but the Panda/Code runs stable.

then its your transformer and/or neon tube producing EMI !

Please swap relay outputs to prove that it remains when you do so - I have no doubt it still will be affected on a different relay.

Pulling the tube out simply means the transformer won’t be working so you can’t use that test to discern which is working and which is not. Your next trial might simply be to replace the old dodgy transformer with new modern transformer.

Replacing the old transformer is not easy. I cannot reach it without disassembling some furniture etc.

I hoped to do “something” to fix the issue at the Network Shield. The Panda seems to be protected. It is possible to “apply” this “protection” to the network shield manually?

you could try shielding it - can’t hurt (but be careful). Alfoil, lots of it, protected from contact with the electronics, and taken back to earth, may make a difference. Perhaps a second layer of relay may also help.

Thank you for your help. I will try to shield the Panda and Network Shield…

As a quick test you could try Aluminium foil.

Sorry, yeah, “alfoil” is what we aussies call that… Maybe others do too I don’t know ! :think:

I would normally call it TinFoil (UK) but know that it has several other names depending where you are.

you guys is crazy - when was it made out of tin ??
:wink:

That’s what comes from living in one of the ‘Old’ countries. Tin Foil was around long before Aluminium foil came into use after WWII.

at least you are part way there on the adoption of metric and SI units :wink:

I can’t argue with you there. I went through school being taught metric and then spend nearly all my working life working in imperial! :wall: Now it just seems a mess but if I say it’s 3meters 6inches to a colleague chances are they know exactly what I mean.

We call it tinfoil even though we know what it is made from.