Main Site Documentation

Problem with chipworkX updater


#1

When I try to update using chipworkX updater this error msg is displayed and can’t do anything else. Please help me!


#2

Run as administrator or copy the whole exe file to your desktop then run it as admin.


#3

I am getting this new error when I try to upgrade tinybooter in the same chx module. I also tried the process by console running as administrator and neither works. Please check the image sent and let me know what I can do. Thanks


#4

If this doesn’t work then try manual update please http://wiki.tinyclr.com/index.php?title=Firmware_Update


#5

Neither works!..I got this error msg. Running as administrator and following the jumper instructions as adviced.


#6

Exactly :slight_smile:

Why do you have so many COM ports on your system. I am curious. And which one is the correct one for CWX?

Remove the jumper on the CWX module and plug in chipworkX while observing the device manager. Which COM port pops up?


#7

Com 16 as showed in the attachment file.


#8

Yeah but the script above didn’t see it.

Try to remove/disable your bluetooth so COM port count is something reasonable and try again.

The other option is to use another PC to update.


#9

Exactly the same results but with Com2


#10

Did you put jumper back before running the update?


#11

Yes, I changed the pc and same result. Some missing file or corrupted one?..


#12

Did you use com2 or COM2?


#13

Right now COM1 and this is the error msg. It’s the same got it with chipworkX Updater.exe


#14

Be carfeul with the character case : it should be com1 and not COM1 or Com1 :hand:

Or com2 if it’s COM2, of course :wink:


#15

Thanks a lot for your help!. It seems this was already overcome, but right now the problem is what is showed above.


#16

is it possible that the “external ram to run applets” error is actually an issue with the app running on the PC? Can you try out the regular update process again instead of the updater - do you get the same or something different now?


#17

The image sent corresponds to the regular update process. What I meant was that this is the same error got with the updater. Both images have been sent to support and are here in this forum for checking out. Thanks


#18

Gentlemen

I really need to solve this. Any idea or suggestion will be really appreciated. Thanks


#19

Just to tripe or quadruple this, we tried it again and it worked flawlessly using the updater and using manual update.


#20

Copy ChipworkX updater to the desktop then run it from there. Or run at as administrator.