Main Site Documentation

Problem updating firmware


#1

I have problems updating the firmware of my FEZDomino. When I upload the firmware in:

c:\Program Files\GHI Electronics\GHI NETMF v4.1 SDK\USBizi\Firmware\

I get the error:

Bad Firmware.

back from the bootloader.

I uploaded using XMODEM and the 1K setting.

When I use the ‘V’ command I get back:

1.07

Am I missing something?


#2

Ah, we seem to be seeing this a few times now.,

If you see the “bad firmware” message, can you uninstall your terra term, reinstall the one downloaded from this site and try again.


#3

Nope, reinstalling didn’t work.

Initially, I accidentally sent firmware using the File->Send File command and had to break it off. I subsequently used the Transfer -> XModem command. Does the X command write all the bytes it receives straight to flash? Maybe there are still some bad bytes in memory somewhere.

I noticed that when I use the ‘R’ command it also returns the ‘Bad Firmware’ error. Note that erasing first with ‘E’ makes no difference, any subsequent uploads still give the ‘Bad Firmware’ error.

Has anyone successfully upgraded their FEZDomino to the new 4.1.1.0 firmware?


#4

Solved it!

I uploaded the firmware using HyperTerminal instead of TeraTerm and it worked without a hitch.

I believe it may have something to do with the fact that the Flow Control in HyperTerminal is set to ‘Hardware’ by default and in TeraTerm it’s set to ‘None’. This may result in errors during transmission which may lead to a failed checksum test.